summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-08 11:02:30 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-03-15 14:12:24 -0500
commit8e4ed3a82a25e76e75ec9549e55ea88b9038817e (patch)
tree98d6dbd700d063ed02b74b73a5f967b65cf82d4b /recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
parent2937fddb56d51cf0c4187396eb7e778b9237045a (diff)
downloadmeta-freescale-8e4ed3a82a25e76e75ec9549e55ea88b9038817e.tar.gz
imx-alsa-plugins: Set recipe name and PV properly
The recipe allows SRCREV to change while the version stays at 1.0.26, so change the recipe version to git and set PV based on the SRCREV. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb')
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
deleted file mode 100644
index e05ba5b2..00000000
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2019 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale alsa-lib plugins"
6LICENSE = "GPL-2.0-only"
7SECTION = "multimedia"
8DEPENDS = "alsa-lib"
9
10# For backwards compatibility
11PROVIDES += "fsl-alsa-plugins"
12RREPLACES:${PN} = "fsl-alsa-plugins"
13RPROVIDES:${PN} = "fsl-alsa-plugins"
14RCONFLICTS:${PN} = "fsl-alsa-plugins"
15
16LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
17
18inherit autotools pkgconfig use-imx-headers
19
20SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
21SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}"
22SRCREV = "cde60d68ab2acee913dbfacb8aabb53d87dd3e38"
23
24S = "${WORKDIR}/git"
25
26INCLUDE_DIR = "-I${STAGING_INCDIR_IMX}"
27
28EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}""
29
30INSANE_SKIP:${PN} = "dev-so"
31
32FILES:${PN} += "${libdir}/alsa-lib/libasound_*.so"
33FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug"
34FILES:${PN}-dev += "${libdir}/alsa-lib/*.la"
35
36COMPATIBLE_MACHINE = "(imx-nxp-bsp)"