summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-04-17 14:48:32 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-25 18:58:26 -0300
commitcaff565e628bf14fae1e5b861c950550de1357d5 (patch)
treea5274279f2a8da5d4038eea89c6bb7ab84e22998 /recipes-kernel
parent2afea5dae14931aca6352269b004bff443391d9c (diff)
downloadmeta-freescale-caff565e628bf14fae1e5b861c950550de1357d5.tar.gz
linux-qoriq/4.9: support big endian
*kernel bigendian option is enabled Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.9.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb
index 7229b014..f6d29429 100644
--- a/recipes-kernel/linux/linux-qoriq_4.9.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.9.bb
@@ -1,4 +1,4 @@
1inherit kernel qoriq_build_64bit_kernel 1inherit kernel qoriq_build_64bit_kernel siteinfo
2inherit fsl-kernel-localversion 2inherit fsl-kernel-localversion
3 3
4SUMMARY = "Linux Kernel for Freescale QorIQ platforms" 4SUMMARY = "Linux Kernel for Freescale QorIQ platforms"
@@ -36,6 +36,12 @@ do_merge_delta_config() {
36 # create .config with make config 36 # create .config with make config
37 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} 37 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG}
38 38
39 # check if bigendian is enabled
40 if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then
41 echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config
42 echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config
43 fi
44
39 # add config fragments 45 # add config fragments
40 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do 46 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
41 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then 47 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then