summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-10-31 14:56:26 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-10-31 15:09:09 -0700
commit7c0c9b0f3d790bc419e5145a4993630500a13a66 (patch)
tree19871ef0b42ff74fc580a83c2f293f5712db30ae /recipes-kernel
parent37bd435c44dbd8dc38d633b109f131952b9e221f (diff)
downloadmeta-freescale-7c0c9b0f3d790bc419e5145a4993630500a13a66.tar.gz
kernel-module-nxp-wlan: Fix REGULATORY_IGNORE_STALE_KICKOFF build break
Apply patch to fix build for kernels 6.1.39 and greater. Fixes: #1676 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp-wlan/0001-moal_cfg80211-remove-dropped-REGULATORY_IGNORE_STALE.patch34
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/0001-moal_cfg80211-remove-dropped-REGULATORY_IGNORE_STALE.patch b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/0001-moal_cfg80211-remove-dropped-REGULATORY_IGNORE_STALE.patch
new file mode 100644
index 00000000..5b837310
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan/0001-moal_cfg80211-remove-dropped-REGULATORY_IGNORE_STALE.patch
@@ -0,0 +1,34 @@
1From 223ec51667cfdc6339b5c74a65c87e0e8ad970b5 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Tue, 31 Oct 2023 14:49:12 -0700
4Subject: [PATCH] moal_cfg80211: remove dropped REGULATORY_IGNORE_STALE_KICKOFF
5
6Upstream commit e8c2af660ba0 ("wifi: cfg80211: fix regulatory disconnect with
7OCB/NAN") removed the definition of REGULATORY_IGNORE_STALE_KICKOFF. Fix the
8driver code to indicate Kernel version where it is no longer available.
9
10Link: https://lore.kernel.org/r/20230616222844.2794d1625a26.I8e78a3789a29e6149447b3139df724a6f1b46fc3@changeid
11
12Upstream-Status: Pending
13Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
14Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
15---
16 mxm_wifiex/wlan_src/mlinux/moal_sta_cfg80211.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/mxm_wifiex/wlan_src/mlinux/moal_sta_cfg80211.c b/mxm_wifiex/wlan_src/mlinux/moal_sta_cfg80211.c
20index bf39f0e..8a69d32 100644
21--- a/mxm_wifiex/wlan_src/mlinux/moal_sta_cfg80211.c
22+++ b/mxm_wifiex/wlan_src/mlinux/moal_sta_cfg80211.c
23@@ -10357,7 +10357,7 @@ mlan_status woal_register_cfg80211(moal_private *priv)
24 PRINTM(MIOCTL, "Follow countryIE provided by AP.\n");
25 }
26 #endif
27-#if CFG80211_VERSION_CODE >= KERNEL_VERSION(3, 19, 0)
28+#if (CFG80211_VERSION_CODE >= KERNEL_VERSION(3, 19, 0)) && (CFG80211_VERSION_CODE < KERNEL_VERSION(6, 1, 39))
29 /*REGULATORY_IGNORE_STALE_KICKOFF: the regulatory core will _not_ make
30 * sure all interfaces on this wiphy reside on allowed channels. If this
31 * flag is not set, upon a regdomain change, the interfaces are given a
32--
332.25.1
34
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
index db385d18..d5258e77 100644
--- a/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp-wlan_git.bb
@@ -10,7 +10,8 @@ RCONFLICTS:${PN} = "kernel-module-nxp89xx"
10 10
11SRCBRANCH = "lf-6.1.22_2.0.0" 11SRCBRANCH = "lf-6.1.22_2.0.0"
12MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https" 12MRVL_SRC ?= "git://github.com/nxp-imx/mwifiex.git;protocol=https"
13SRC_URI = "${MRVL_SRC};branch=${SRCBRANCH}" 13SRC_URI = "${MRVL_SRC};branch=${SRCBRANCH} \
14 file://0001-moal_cfg80211-remove-dropped-REGULATORY_IGNORE_STALE.patch;patchdir=${WORKDIR}/git"
14SRCREV = "f1382ccbd34fc22daf504e798745f6cddb702b82" 15SRCREV = "f1382ccbd34fc22daf504e798745f6cddb702b82"
15 16
16S = "${WORKDIR}/git/mxm_wifiex/wlan_src" 17S = "${WORKDIR}/git/mxm_wifiex/wlan_src"