summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-05-05 17:13:55 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-06 15:52:09 -0300
commit7832f6e2ba1df4ab3859fe86cc6340430df8a198 (patch)
tree1468e342a85418073ef5ba00a07c6ff81dfb7847 /recipes-kernel
parentcfd5784236ca631215cdefa21dfe36f6f194eb47 (diff)
downloadmeta-freescale-7832f6e2ba1df4ab3859fe86cc6340430df8a198.tar.gz
linux-imx-[mfgtool]-5.4.3: update recipes to align with kernel-yocto
When kernel-yocto class is inherited by kernel recipes, the way how PV is constructed changes to reflect GIT kernel tags and meta information. This causes the fetcher search to fail, since paths used to locate files are compiled from PV. Replace version-specific paths in recipes to use PN instead, which is registered in the fetcher as a valid search location. Linux kernel recipe should have LINUX_VERSION also defined, since it is used by kernel-yocto class to derive PV. This version is set to the real kernel version provided by NXP in their source tree. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_5.4.3.bb2
-rw-r--r--recipes-kernel/linux/linux-imx/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch (renamed from recipes-kernel/linux/linux-imx-5.4.3/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch)0
-rw-r--r--recipes-kernel/linux/linux-imx/imx/defconfig (renamed from recipes-kernel/linux/linux-imx-5.4.3/imx/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-imx/mx8/defconfig (renamed from recipes-kernel/linux/linux-imx-5.4.3/mx8/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-imx_5.4.3.bb10
5 files changed, 11 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_5.4.3.bb b/recipes-kernel/linux/linux-imx-mfgtool_5.4.3.bb
index 543fe980..0a9f5259 100644
--- a/recipes-kernel/linux/linux-imx-mfgtool_5.4.3.bb
+++ b/recipes-kernel/linux/linux-imx-mfgtool_5.4.3.bb
@@ -5,7 +5,7 @@ SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \ 5DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \
6Manufacturing Tool compatible Linux Kernel to be used in updater environment" 6Manufacturing Tool compatible Linux Kernel to be used in updater environment"
7 7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx-${PV}:" 8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-imx:"
9require linux-imx_${PV}.bb 9require linux-imx_${PV}.bb
10require linux-mfgtool.inc 10require linux-mfgtool.inc
11 11
diff --git a/recipes-kernel/linux/linux-imx-5.4.3/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch b/recipes-kernel/linux/linux-imx/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
index e3df8084..e3df8084 100644
--- a/recipes-kernel/linux/linux-imx-5.4.3/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
+++ b/recipes-kernel/linux/linux-imx/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
diff --git a/recipes-kernel/linux/linux-imx-5.4.3/imx/defconfig b/recipes-kernel/linux/linux-imx/imx/defconfig
index 622e5430..622e5430 100644
--- a/recipes-kernel/linux/linux-imx-5.4.3/imx/defconfig
+++ b/recipes-kernel/linux/linux-imx/imx/defconfig
diff --git a/recipes-kernel/linux/linux-imx-5.4.3/mx8/defconfig b/recipes-kernel/linux/linux-imx/mx8/defconfig
index 4decab9e..4decab9e 100644
--- a/recipes-kernel/linux/linux-imx-5.4.3/mx8/defconfig
+++ b/recipes-kernel/linux/linux-imx/mx8/defconfig
diff --git a/recipes-kernel/linux/linux-imx_5.4.3.bb b/recipes-kernel/linux/linux-imx_5.4.3.bb
index 3d4fa864..6c042184 100644
--- a/recipes-kernel/linux/linux-imx_5.4.3.bb
+++ b/recipes-kernel/linux/linux-imx_5.4.3.bb
@@ -2,6 +2,9 @@
2# Copyright 2017-2019 (C) NXP 2# Copyright 2017-2019 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA. 3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
5 8
6SUMMARY = "Linux Kernel provided and supported by NXP" 9SUMMARY = "Linux Kernel provided and supported by NXP"
7DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \ 10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
@@ -18,6 +21,13 @@ SRCBRANCH = "lf-5.4.y"
18LOCALVERSION = "-1.0.0" 21LOCALVERSION = "-1.0.0"
19SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466" 22SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466"
20 23
24# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
25# required by kernel-yocto.bbclass.
26#
27# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
28# should be updated once patchlevel is merged.
29LINUX_VERSION = "5.4.3"
30
21SRC_URI += "file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch" 31SRC_URI += "file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch"
22 32
23DEFAULT_PREFERENCE = "1" 33DEFAULT_PREFERENCE = "1"