summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2023-10-30 16:31:36 +0100
committerAndrey Zhizhikin <andrey.z@gmail.com>2023-10-30 21:13:23 +0100
commit655210018c7ab23b2c48dffdd47f16a516bd40c5 (patch)
tree4bef91167b8d33059e7e719c773a72709e10a119 /recipes-kernel
parent727ec1c3e72d401c26e4ba6abbfa1c8f634938c9 (diff)
downloadmeta-freescale-655210018c7ab23b2c48dffdd47f16a516bd40c5.tar.gz
linux-fslc: upgrade to 6.6.x+fslc
Kernel 6.6 has been oficially released [1], and new FSLC branch is available in linux-fslc repository. Pick up the latest kernel branch from linux-fslc repository. Following commits are added on top of stable tree: ---- 9626dbfbc45e ("kbuild: filter only valid dtb files to construct complex dtb") 167b77773406 ("ARM64: defconfig: Enable KPROBES so allow LTTng use") 0c15d80246ad ("ARM: mxs_defconfig: Enable KPROBES so allow LTTng use") 8f644ae0ed1f ("ARM: imx_v6_v7_defconfig: Remove evbug as it is not normally used") a3e3a8c622d6 ("media: coda: Change firmware probing order") 921cd57b50e8 ("drivers, misc: add U-Boot bootcount driver") 1eb694eaae5d ("fec: Add disable_giga parameter to force 10/100 operation") fd23fe4e28e3 ("MA-7633-2 [Android-Reboot]reboot to fastboot\recovery mode") 088037fbdde4 ("ARM: imx: add cpu_is_imx6() routine") ---- Link: [1]: https://lore.kernel.org/lkml/CAHk-=wiZuU984NWVgP4snp8sEt4Ux5Mp_pxAN5MNV9VpcGUo+A@mail.gmail.com/ Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc_6.6.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc_6.6.bb b/recipes-kernel/linux/linux-fslc_6.6.bb
new file mode 100644
index 00000000..3365f778
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc_6.6.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2012-2019 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "FSL Community BSP Linux mainline based kernel with backported features and fixes"
8DESCRIPTION = "Linux kernel based on mainline kernel used by FSL Community BSP in order to \
9provide support for some backported features and fixes, or because it was applied in linux-next \
10and takes some time to become part of a stable version, or because it is not applicable for \
11upstreaming."
12
13require linux-imx.inc
14
15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
16
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass.
19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.6"
23
24KBRANCH = "6.6.x+fslc"
25SRCREV = "34836895e19e910f736b06d7dbe522f4a33857f8"
26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
29KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
30KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"
31KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v6_v7_defconfig"
32KBUILD_DEFCONFIG:mx8-generic-bsp = "defconfig"
33KBUILD_DEFCONFIG:mx9-generic-bsp = "defconfig"
34KBUILD_DEFCONFIG:mxs-generic-bsp = "mxs_defconfig"
35KBUILD_DEFCONFIG:vf-generic-bsp = "imx_v6_v7_defconfig"
36
37LOCALVERSION = "-fslc"
38
39COMPATIBLE_MACHINE = "(imx-generic-bsp)"