diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-02-23 22:12:29 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-02-23 19:38:02 -0300 |
commit | 14d5961c133ab4724e3e6ad66f2cc0ca21dc19ba (patch) | |
tree | b3afadff2717effedac960299aab945b80ad02f0 /recipes-kernel | |
parent | f20facb231c83a8328bdfdfb5ac90cb3b439473b (diff) | |
download | meta-freescale-14d5961c133ab4724e3e6ad66f2cc0ca21dc19ba.tar.gz |
linux-fslc-imx: update to v5.4.99
Kernel repository has been upgraded to v5.4.99 from stable korg.
Following upstream commits are included in this version:
----
850e6a95deb5 Linux 5.4.99
e8ffaca0fe27 ovl: expand warning in ovl_d_real()
b55528a18e40 net/qrtr: restrict user-controlled length in qrtr_tun_write_iter()
99996cd558ba net/rds: restrict iovecs length for RDS_CMSG_RDMA_ARGS
ac79b1d94a88 vsock: fix locking in vsock_shutdown()
c025081b57df vsock/virtio: update credit only if socket is not closed
2545c5bd8316 net: watchdog: hold device global xmit lock during tx disable
a5f0b6f7b1c0 net/vmw_vsock: improve locking in vsock_connect_timeout()
611d93fbea54 net: fix iteration for sctp transport seq_files
2085d886630a net: gro: do not keep too many GRO packets in napi->rx_list
5c53956a8da0 net: dsa: call teardown method on probe failure
0b42ab078369 udp: fix skb_copy_and_csum_datagram with odd segment sizes
73bc75fda669 rxrpc: Fix clearance of Tx/Rx ring when releasing a call
b90e8d5d28d1 usb: dwc3: ulpi: Replace CPU-based busyloop with Protocol-based one
35834bf0b210 usb: dwc3: ulpi: fix checkpatch warning
0b49b82eeea2 h8300: fix PREEMPTION build, TI_PRE_COUNT undefined
1019015a5dca i2c: stm32f7: fix configuration of the digital filter
546d92a43c94 clk: sunxi-ng: mp: fix parent rate change flag check
b02db23d2647 drm/sun4i: dw-hdmi: Fix max. frequency for H6
40db7dba50fe drm/sun4i: Fix H6 HDMI PHY configuration
3063b80b4bdf drm/sun4i: tcon: set sync polarity for tcon1 channel
107cf5eede74 firmware_loader: align .builtin_fw to 8
beb85f4927e8 net: hns3: add a check for queue_id in hclge_reset_vf_queue()
a045956a3b41 x86/build: Disable CET instrumentation in the kernel for 32-bit too
da1a5442ad2c netfilter: conntrack: skip identical origin tuple in same zone only
0142b957866f ibmvnic: Clear failover_pending if unable to schedule
3f8954cc624c net: stmmac: set TxQ mode back to DCB after disabling CBS
c0daa74b8ed7 selftests: txtimestamp: fix compilation issue
6107338c2fa2 net: enetc: initialize the RFS and RSS memories
71d2bd7921db xen/netback: avoid race in xenvif_rx_ring_slots_available()
ff758e8a77f3 netfilter: flowtable: fix tcp and udp header checksum update
b110391d1e80 netfilter: nftables: fix possible UAF over chains from packet path in netns
35c279e02b7e netfilter: xt_recent: Fix attempt to update deleted entry
7e3a6b820535 bpf: Check for integer overflow when using roundup_pow_of_two()
e29126678f65 drm/vc4: hvs: Fix buffer overflow with the dlist handling
69beec4a8b36 mt76: dma: fix a possible memory leak in mt76_add_fragment()
8a5991c8214b lkdtm: don't move ctors to .rodata
4f5416710e13 vmlinux.lds.h: Create section for protection against instrumentation
b7f41a7ad444 ARM: kexec: fix oops after TLB are invalidated
f49bff85b6db ARM: ensure the signal page contains defined contents
06350c7f7923 ARM: dts: lpc32xx: Revert set default clock rate of HCLK PLL
e60577e29deb bfq-iosched: Revert "bfq: Fix computation of shallow depth"
91d604ab2a99 riscv: virt_addr_valid must check the address belongs to linear mapping
0db8d192ee57 drm/amd/display: Decrement refcount of dc_sink before reassignment
5c8f63266255 drm/amd/display: Free atomic state after drm_atomic_commit
f35da70b516f drm/amd/display: Fix dc_sink kref count in emulated_link_detect
76979956a8af drm/amd/display: Add more Clock Sources to DCN2.1
4516a0a2c087 nvme-pci: ignore the subsysem NQN on Phison E16
335a285aa0f0 ovl: skip getxattr of security labels
43e3cf46afb1 cap: fix conversions on getxattr
df094aa0aab0 ovl: perform vfs_getxattr() with mounter creds
cc512646b2e7 platform/x86: hp-wmi: Disable tablet-mode reporting by default
2bb22cd4dae4 ARM: OMAP2+: Fix suspcious RCU usage splats for omap_enter_idle_coupled
2cb208ba0fd1 arm64: dts: qcom: sdm845: Reserve LPASS clocks in gcc
92c40ed0abcb arm64: dts: rockchip: Fix PCIe DT properties on rk3399
2407794f2298 cgroup: fix psi monitor for root cgroup
18d691d837b3 arm/xen: Don't probe xenbus as part of an early initcall
a0997a86f5c0 tracing: Check length before giving out the filter buffer
74c7bafdd303 tracing: Do not count ftrace events in top level enable output
4851d7b340e9 gpio: ep93xx: Fix single irqchip with multi gpiochips
2c5abe0f8e9c gpio: ep93xx: fix BUG_ON port F usage
----
Link: https://lore.kernel.org/r/20210215152715.401453874@linuxfoundation.org
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_5.4.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb index 60f7e0fe..6688bc0a 100644 --- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb +++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb | |||
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v5.4.98 | 31 | # tag: v5.4.99 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
@@ -73,14 +73,14 @@ LICENSE = "GPLv2" | |||
73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
74 | 74 | ||
75 | SRCBRANCH = "5.4-2.1.x-imx" | 75 | SRCBRANCH = "5.4-2.1.x-imx" |
76 | SRCREV = "bef3e06d83685406b847623947543314c7318b07" | 76 | SRCREV = "42b69f37b02cb3e1a585c317a413f99e81b0f5c2" |
77 | 77 | ||
78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
79 | # required by kernel-yocto.bbclass. | 79 | # required by kernel-yocto.bbclass. |
80 | # | 80 | # |
81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
82 | # should be updated once patchlevel is merged. | 82 | # should be updated once patchlevel is merged. |
83 | LINUX_VERSION = "5.4.98" | 83 | LINUX_VERSION = "5.4.99" |
84 | 84 | ||
85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. | 85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. |
86 | LOCALVERSION = "-imx-5.4.24-2.1.0" | 86 | LOCALVERSION = "-imx-5.4.24-2.1.0" |