diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-12-12 21:05:50 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-12 18:42:12 -0300 |
commit | 14b0904dc12a03ccbcaebf9be1f7eaa6a1411c83 (patch) | |
tree | 688b442764fa2c37c947fa843f9f3aa53347b9a5 /recipes-kernel | |
parent | 587f2781a798da241a64d3d80d49661358ad6db5 (diff) | |
download | meta-freescale-14b0904dc12a03ccbcaebf9be1f7eaa6a1411c83.tar.gz |
linux-fslc-imx: update to v5.4.83
Kernel repository has been upgraded to v5.4.83 from stable korg.
Following conflicts were resolved during merge:
----
- drivers/i2c/busses/i2c-imx.c:
Merge commits 0af141327c87 ("i2c: imx: correct code of errata A-010650
for layerscape platform") from NXP tree with commit 83366a7b2d34 ("i2c:
imx: Fix reset of I2SR_IAL flag") from upstream, replace the function
i2c_imx_clr_if_bit in NXP tree to i2c_imx_clear_irq from upstream.
----
Following upstream commits are included in this version:
----
2bff021f53b2 Linux 5.4.83
66a08d1d3bd8 Revert "geneve: pull IP header before ECN decapsulation"
ed58971beb47 x86/insn-eval: Use new for_each_insn_prefix() macro to loop over prefixes bytes
423e1b08ce5c netfilter: nftables_offload: set address type in control dissector
13995410b616 netfilter: nf_tables: avoid false-postive lockdep splat
f25fa580f99e Input: i8042 - fix error return code in i8042_setup_aux()
b9df537e5fcd dm writecache: remove BUG() and fail gracefully instead
8e2c50315f00 i2c: qup: Fix error return code in qup_i2c_bam_schedule_desc()
1015eefe10e2 rtw88: debug: Fix uninitialized memory in debugfs code
af699e99efdc ASoC: wm_adsp: fix error return code in wm_adsp_load()
fdc1416c2199 tipc: fix a deadlock when flushing scheduled work
6410c7f53698 netfilter: ipset: prevent uninit-value in hash_ip6_add
cd928d387b0b gfs2: check for empty rgrp tree in gfs2_ri_update
c358e7e99dda can: af_can: can_rx_unregister(): remove WARN() statement from list operation sanity check
867fbf2bb739 lib/syscall: fix syscall registers retrieval on 32-bit platforms
f68f5bdfefd9 tracing: Fix userstacktrace option for instances
dbbf6cdab503 iommu/amd: Set DTE[IntTabLen] to represent 512 IRTEs
d863a4ad3cc5 spi: bcm2835: Release the DMA channel if probe fails after dma_init
83d5121c3b0f i2c: imx: Check for I2SR_IAL after every byte
83366a7b2d34 i2c: imx: Fix reset of I2SR_IAL flag
b0d4fa10bfcc speakup: Reject setting the speakup line discipline outside of speakup
a2a163f70bdf mm/swapfile: do not sleep with a spin lock held
4870004d30e3 mm: list_lru: set shrinker map bit when child nr_items is not zero
42ccf9d14ede coredump: fix core_pattern parse error
579c977253b6 x86/uprobes: Do not use prefixes.nbytes when looping over prefixes.bytes
002d2c4a3f66 dm: remove invalid sparse __acquires and __releases annotations
3b02d67064ff dm: fix bug with RCU locking in dm_blk_report_zones
7eb514087cdd powerpc/pseries: Pass MSI affinity to irq_create_mapping()
1f72986fc9df genirq/irqdomain: Add an irq_create_mapping_affinity() function
6466119452a8 powerpc/64s/powernv: Fix memory corruption when saving SLB entries on MCE
8a758e97b707 dm writecache: fix the maximum number of arguments
3f680c5996f9 scsi: mpt3sas: Fix ioctl timeout
812dff6a5250 drm/i915/gt: Program mocs:63 for cache eviction on gen9
b92738c4f9d3 thunderbolt: Fix use-after-free in remove_unplugged_switch()
ed201cb54d6f i2c: imx: Don't generate STOP condition if arbitration has been lost
73948ab9f2df cifs: fix potential use-after-free in cifs_echo_request()
a0ca8cb2f707 cifs: allow syscalls to be restarted in __smb_send_rqst()
205740ca4a4d ftrace: Fix updating FTRACE_FL_TRAMP
d18379bbb856 ALSA: hda/generic: Add option to enforce preferred_dacs pairs
f28666e00a44 ALSA: hda/realtek - Add new codec supported for ALC897
c57556f1798b ALSA: hda/realtek: Enable headset of ASUS UX482EG & B9400CEA with ALC294
f3fc36614438 ALSA: hda/realtek: Add mute LED quirk to yet another HP x360 model
de41002d2e0e ALSA: hda/realtek: Fix bass speaker DAC assignment on Asus Zephyrus G14
35ee9ac51328 tty: Fix ->session locking
c536ecd48560 tty: Fix ->pgrp locking in tiocspgrp()
013d2d046532 USB: serial: option: fix Quectel BG96 matching
3cf949422734 USB: serial: option: add support for Thales Cinterion EXS82
0f8af69bec41 USB: serial: option: add Fibocom NL668 variants
250930f60c33 USB: serial: ch341: sort device-id entries
25b90f887dd4 USB: serial: ch341: add new Product ID for CH341A
f0990c21af7d USB: serial: kl5kusb105: fix memleak on open
8954745718e7 usb: gadget: f_fs: Use local copy of descriptors for userspace copy
4a77729b25d6 Partially revert bpf: Zero-fill re-used per-cpu map element
512b18eec5c2 pinctrl: baytrail: Fix pin being driven low for a while on gpiod_get(..., GPIOD_OUT_HIGH)
e90d11d0be10 pinctrl: baytrail: Replace WARN with dev_info_once when setting direct-irq pin to output
----
Link: https://lore.kernel.org/r/20201210164728.074574869@linuxfoundation.org
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_5.4.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb index 24686195..beb97a48 100644 --- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb +++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb | |||
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v5.4.82 | 31 | # tag: v5.4.83 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
@@ -73,14 +73,14 @@ LICENSE = "GPLv2" | |||
73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
74 | 74 | ||
75 | SRCBRANCH = "5.4-2.1.x-imx" | 75 | SRCBRANCH = "5.4-2.1.x-imx" |
76 | SRCREV = "e7d7739c920d256d842d79959a3447f69d378050" | 76 | SRCREV = "20467a016a344fd78faeacddfe5027441cc4f94f" |
77 | 77 | ||
78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
79 | # required by kernel-yocto.bbclass. | 79 | # required by kernel-yocto.bbclass. |
80 | # | 80 | # |
81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
82 | # should be updated once patchlevel is merged. | 82 | # should be updated once patchlevel is merged. |
83 | LINUX_VERSION = "5.4.82" | 83 | LINUX_VERSION = "5.4.83" |
84 | 84 | ||
85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. | 85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. |
86 | LOCALVERSION = "-imx-5.4.24-2.1.0" | 86 | LOCALVERSION = "-imx-5.4.24-2.1.0" |