summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.14.bb
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2020-04-07 12:32:47 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-07 16:09:42 -0300
commit6f63fe25adb4935a71255823891749fed0fbdeb9 (patch)
tree119bfd012a0bd58c89d6a6985ef16dd7bb334569 /recipes-kernel/linux/linux-qoriq_4.14.bb
parent69652b4462808810ac189af030d9fc13a89e3b27 (diff)
downloadmeta-freescale-6f63fe25adb4935a71255823891749fed0fbdeb9.tar.gz
linux-qoriq: harmonize kernel recipes
Move everything which is common used of linux-qoriq kernels into linux-qoriq.inc and require it from both existing kernel recipes. This should avoid copy'n'waste even for future kernels. Signed-off-by: Jens Rehsack <sno@netbsd.org>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.14.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.14.bb64
1 files changed, 1 insertions, 63 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb
index 36c2e96b..33361131 100644
--- a/recipes-kernel/linux/linux-qoriq_4.14.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.14.bb
@@ -1,9 +1,3 @@
1inherit kernel qoriq_build_64bit_kernel siteinfo
2inherit fsl-kernel-localversion
3
4SUMMARY = "Linux Kernel for NXP QorIQ platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 1LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
8 2
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ 3SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
@@ -12,60 +6,4 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nob
12" 6"
13SRCREV = "d39cc9ffcbe5638b50f5f45698eb87a6c3a96eb3" 7SRCREV = "d39cc9ffcbe5638b50f5f45698eb87a6c3a96eb3"
14 8
15S = "${WORKDIR}/git" 9require recipes-kernel/linux/linux-qoriq.inc
16
17DEPENDS_append = " libgcc"
18# not put Images into /boot of rootfs, install kernel-image if needed
19RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
20
21KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
22KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
23KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
24
25ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
26ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
27
28SCMVERSION ?= "y"
29LOCALVERSION = ""
30DELTA_KERNEL_DEFCONFIG ?= ""
31DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config "
32DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config "
33DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config "
34
35do_merge_delta_config[dirs] = "${B}"
36
37do_merge_delta_config() {
38 # create config with make config
39 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG}
40
41 # check if bigendian is enabled
42 if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then
43 echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config
44 echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config
45 fi
46
47 # add config fragments
48 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
49 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then
50 oe_runmake -C ${S} O=${B} ${deltacfg}
51 elif [ -f "${WORKDIR}/${deltacfg}" ]; then
52 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
53 elif [ -f "${deltacfg}" ]; then
54 ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg}
55 fi
56 done
57 cp .config ${WORKDIR}/defconfig
58}
59addtask merge_delta_config before do_preconfigure after do_patch
60
61# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
62do_compile_prepend_fsl-lsch2-32b() {
63 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
64}
65
66do_install_prepend_fsl-lsch2-32b() {
67 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
68}
69
70FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
71COMPATIBLE_MACHINE = "(qoriq)"