summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.14.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-04-17 14:48:31 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-25 18:58:26 -0300
commit2afea5dae14931aca6352269b004bff443391d9c (patch)
tree4c0a632672ff4a5892d32e1bd54119574b71b4c8 /recipes-kernel/linux/linux-qoriq_4.14.bb
parenta7f2cee408e28086b69dd63b89cb7888b8c94458 (diff)
downloadmeta-freescale-2afea5dae14931aca6352269b004bff443391d9c.tar.gz
linux-qoriq/4.14: support big endian
*kernel bigendian option is enabled Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.14.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.14.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb
index 0a708fe1..f4af8d52 100644
--- a/recipes-kernel/linux/linux-qoriq_4.14.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.14.bb
@@ -1,4 +1,4 @@
1inherit kernel qoriq_build_64bit_kernel 1inherit kernel qoriq_build_64bit_kernel siteinfo
2inherit fsl-kernel-localversion 2inherit fsl-kernel-localversion
3 3
4SUMMARY = "Linux Kernel for NXP QorIQ platforms" 4SUMMARY = "Linux Kernel for NXP QorIQ platforms"
@@ -36,6 +36,12 @@ do_merge_delta_config() {
36 # create config with make config 36 # create config with make config
37 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} 37 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG}
38 38
39 # check if bigendian is enabled
40 if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then
41 echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config
42 echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config
43 fi
44
39 # add config fragments 45 # add config fragments
40 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do 46 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
41 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then 47 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then