summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-08-12 18:43:49 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:43:43 -0300
commit63c4151083e8bca01607b61089d1e0634809c9fb (patch)
tree26096f9832fcd03b4f2919c907b38a148e21fa84 /recipes-kernel/linux/linux-qoriq
parent1711129869e58329e30bd40a0aa9cc9c06ffead6 (diff)
downloadmeta-freescale-63c4151083e8bca01607b61089d1e0634809c9fb.tar.gz
linux-qoriq: fix build path of the dtb
Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq')
-rw-r--r--recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch b/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch
new file mode 100644
index 00000000..1103f0c2
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/powerpc-fsl-Fix-build-of-the-dtb-embedded-kernel-images.patch
@@ -0,0 +1,45 @@
1From 4680c9d50637f78338e786c920aef6c171c7cc00 Mon Sep 17 00:00:00 2001
2From: Alessio Igor Bogani <alessio.bogani@elettra.eu>
3Date: Mon, 18 Apr 2016 08:36:19 +0200
4Subject: powerpc/fsl: Fix build of the dtb embedded kernel images
5
6Commit dc37374b9c833 ("powerpc/fsl: Move Freescale device tree files
7into fsl folder") moved a lot of device tree files into fsl directory,
8fixing Makefile for cuImage target only. Unfortunately there are other
9targets which require embedding a device tree into the kernel image
10(e.g. dtbImage.%). So use a more generic approach.
11
12Signed-off-by: Alessio Igor Bogani <alessio.bogani@elettra.eu>
13[scottwood: cleaned up commit message]
14Signed-off-by: Scott Wood <oss@buserror.net>
15---
16 arch/powerpc/boot/Makefile | 6 +++---
17 1 file changed, 3 insertions(+), 3 deletions(-)
18
19diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
20index 6116510..8fe78a3 100644
21--- a/arch/powerpc/boot/Makefile
22+++ b/arch/powerpc/boot/Makefile
23@@ -362,9 +362,6 @@ $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
24 $(obj)/cuImage.%: vmlinux $(obj)/%.dtb $(wrapperbits)
25 $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb)
26
27-$(obj)/cuImage.%: vmlinux $(obj)/fsl/%.dtb $(wrapperbits)
28- $(call if_changed,wrap,cuboot-$*,,$(obj)/fsl/$*.dtb)
29-
30 $(obj)/simpleImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
31 $(call if_changed,wrap,simpleboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz)
32
33@@ -381,6 +378,9 @@ $(obj)/treeImage.%: vmlinux $(obj)/%.dtb $(wrapperbits)
34 $(obj)/%.dtb: $(src)/dts/%.dts FORCE
35 $(call if_changed_dep,dtc)
36
37+$(obj)/%.dtb: $(src)/dts/fsl/%.dts FORCE
38+ $(call if_changed_dep,dtc)
39+
40 # If there isn't a platform selected then just strip the vmlinux.
41 ifeq (,$(image-y))
42 image-y := vmlinux.strip
43--
44cgit v0.12
45