summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_6.6.bb
diff options
context:
space:
mode:
authorLuan Rafael Carneiro <luan.rafael@ossystems.com.br>2024-04-12 16:58:55 -0300
committerLuan Rafael Carneiro <luan.rafael@ossystems.com.br>2024-04-12 17:11:31 -0300
commitf6e23a3f3a3c4c54022e4d4d47324219beb37527 (patch)
tree1163f75d0a01bf190ac61221a7611a0350727129 /recipes-kernel/linux/linux-imx_6.6.bb
parent14c284eb5361bd5e7526061ec03a109e2698d08a (diff)
downloadmeta-freescale-f6e23a3f3a3c4c54022e4d4d47324219beb37527.tar.gz
linux-imx: Bump from v6.1.55-2.2.0 to v6.6.3-1.0.0
Signed-off-by: Luan Rafael Carneiro <luan.rafael@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-imx_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_6.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_6.6.bb b/recipes-kernel/linux/linux-imx_6.6.bb
new file mode 100644
index 00000000..409e1f66
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_6.6.bb
@@ -0,0 +1,33 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2023 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15SRCBRANCH = "lf-6.6.y"
16LOCALVERSION = "-6.6.3-1.0.0"
17SRCREV = "ccf0a99701a701fb48a04e31ffe3f9d585a8374a"
18
19# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
20# required by kernel-yocto.bbclass.
21#
22# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
23# should be updated once patchlevel is merged.
24LINUX_VERSION = "6.6.3"
25
26KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
27KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"
28KBUILD_DEFCONFIG:mx8-generic-bsp = "imx_v8_defconfig"
29KBUILD_DEFCONFIG:mx9-generic-bsp = "imx_v8_defconfig"
30
31DEFAULT_PREFERENCE = "1"
32
33COMPATIBLE_MACHINE = "(imx-nxp-bsp)"