summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2016-11-10 15:21:31 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-11-14 14:10:38 -0200
commitfda4c4911f3ba2bbf0d9521c59d266023bc2bf69 (patch)
treef408d0ac62f3a8d7190f07508b68de9d14d1013f /recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
parent0b7c8e0567c3c5d0c9b334bd51218ac02f4d155c (diff)
downloadmeta-freescale-fda4c4911f3ba2bbf0d9521c59d266023bc2bf69.tar.gz
linux-fslc-imx-rt: Upgrade to 4.1-2.0.x GA
Upgrade to revision 176c482, and apply patch 4.1.35-rt41 on top of it. Refresh defconfig for the new kernel version. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
new file mode 100644
index 00000000..fbb32d81
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Realtime version of the FSL Community BSP i.MX6 Linux kernel with backported features and fixes"
2DESCRIPTION = "Linux kernel based on NXP 4.1-2.0.0 GA release, used by FSL Community BSP in order to \
3provide support for i.MX6 based platforms and include official Linux kernel stable updates, backported \
4features and fixes coming from the vendors, kernel community or FSL Community itself. \
5In addition, this kernel has the realtime patch (PREEMPT_RT) applied."
6
7include linux-fslc.inc
8
9PV .= "+git${SRCPV}"
10
11SRCBRANCH = "4.1-2.0.x-imx"
12SRCREV = "176c482f56cd9c523829ceb6bce5c28d3cc6d1c0"
13
14SRC_URI += " \
15 https://www.kernel.org/pub/linux/kernel/projects/rt/4.1/older/patch-4.1.35-rt41.patch.gz;name=rt-patch \
16 file://0001-fix-build.patch \
17 file://0002-no-split-ptlocks.patch \
18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \
19"
20
21SRC_URI[rt-patch.md5sum] = "6dd1193203cdf6a1a4758fc8baf07a4a"
22SRC_URI[rt-patch.sha256sum] = "427e736022e59f83c9489eda889559fcd4fe4abb5646570ade32f2128f2fa725"
23
24python () {
25 using_builtin_driver = (d.getVar("MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE", True) or "") != "1"
26 if not using_builtin_driver:
27 raise bb.parse.SkipPackage('You must use the builtin driver with the Linux RT patch as the external module does not yet include support for it. Set "MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE" accordingly.')
28}
29
30
31COMPATIBLE_MACHINE = "(mx6|mx7)"