summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-01-09 14:43:43 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:24 -0300
commite0ab3df3b2d853db33801ba880683a2619a4d479 (patch)
tree48383b967e2f1b8f4e3fcefad2b8afc7afa68ddd /recipes-kernel/kernel-modules
parentd99968e9b6f3ccaa256d5f31b7d0f676a43ad139 (diff)
downloadmeta-freescale-e0ab3df3b2d853db33801ba880683a2619a4d479.tar.gz
kernel-module-asf: rename back to asf
asf ships not only .ko files, but also scripts. As the recipe inherits module.bbclass, kernel-module-* will be created to package .ko if installed into /lib/modules/. Signed-off-by: Ting Liu <ting.liu@nxp.com>> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-asf_git.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-asf_git.bb b/recipes-kernel/kernel-modules/kernel-module-asf_git.bb
deleted file mode 100644
index a9624e49..00000000
--- a/recipes-kernel/kernel-modules/kernel-module-asf_git.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9RDEPENDS_${PN} += "ipsec-tools"
10
11inherit module qoriq_build_64bit_kernel
12
13S = "${WORKDIR}/git/asfmodule"
14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
16export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
17
18INHIBIT_PACKAGE_STRIP = "1"
19
20do_configure[depends] += "virtual/kernel:do_shared_workdir"
21do_configure_prepend () {
22 find ${S} -name Makefile -exec \
23 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
24}
25
26do_install(){
27 install -d ${D}/${libexecdir}
28 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
30 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
31 cp -rf ${S}/../scripts ${D}/${libexecdir}/
32}
33
34FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
35
36COMPATIBLE_MACHINE = "(qoriq)"