summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/dtc/dtc-145_git.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-07-23 22:13:19 +0200
committerFabio Berton <fabio.berton@ossystems.com.br>2018-07-30 10:42:46 -0300
commit040e4f031f2dc581c48253405da9036def035b68 (patch)
tree629f23aa60de7b14bc11af619dfed40d10ff7b86 /recipes-kernel/dtc/dtc-145_git.bb
parentfd89a85eaafb4f26a11d96db5702eadb83c02813 (diff)
downloadmeta-freescale-040e4f031f2dc581c48253405da9036def035b68.tar.gz
dtc-145: Deploy renamed binary only and add new class
dtc-145-native is used by older U-Boot recipes. U-Boot only depends on the native dtc binary. So, to not clash with files from the regular dtc native build do only install the dtc binary renamed to dtc-145. Also, create a new class to handle with dtc-145 dependency. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/dtc/dtc-145_git.bb')
-rw-r--r--recipes-kernel/dtc/dtc-145_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-kernel/dtc/dtc-145_git.bb b/recipes-kernel/dtc/dtc-145_git.bb
index afed62fd..2776cc5e 100644
--- a/recipes-kernel/dtc/dtc-145_git.bb
+++ b/recipes-kernel/dtc/dtc-145_git.bb
@@ -10,3 +10,9 @@ SRCREV = "22a65c5331c22979d416738eb756b9541672e00d"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12BBCLASSEXTEND = "native nativesdk" 12BBCLASSEXTEND = "native nativesdk"
13
14# only install the dtc binary renamed to dtc-145
15do_install () {
16 install -d ${D}/${bindir}
17 install -m 755 dtc ${D}/${bindir}/dtc-145
18}