summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-07-17 14:57:31 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-07-17 14:57:31 -0700
commite5af88e7fad70374a4ed88311d9459846c40d384 (patch)
treea8bea083decb4d78f806e6f52c2a6546e7d9350c /recipes-graphics
parent29e3b7a59377de22860bc24895afe319715182c5 (diff)
downloadmeta-freescale-e5af88e7fad70374a4ed88311d9459846c40d384.tar.gz
weston-init: Don't add use-g2d where not supported
The logic adding use-g2d to weston.ini adds a commented version for builds without G2D support. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 595633b0..975d8ef1 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -34,6 +34,9 @@ PACKAGECONFIG_SIZE:mx8mq-nxp-bsp ?= "size"
34 34
35SIZE_VALUE:mx8mq-nxp-bsp = "1920x1080" 35SIZE_VALUE:mx8mq-nxp-bsp = "1920x1080"
36 36
37HAS_G2D = "false"
38HAS_G2D:imxgpu2d = "true"
39
37PACKAGECONFIG_USE_G2D ?= "" 40PACKAGECONFIG_USE_G2D ?= ""
38PACKAGECONFIG_USE_G2D:imxgpu2d ?= "use-g2d" 41PACKAGECONFIG_USE_G2D:imxgpu2d ?= "use-g2d"
39PACKAGECONFIG_USE_G2D:mx8qm-nxp-bsp ?= "" 42PACKAGECONFIG_USE_G2D:mx8qm-nxp-bsp ?= ""
@@ -76,7 +79,7 @@ do_install:append() {
76 79
77 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then 80 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then
78 sed -i -e "/^\[core\]/a use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini 81 sed -i -e "/^\[core\]/a use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
79 else 82 elif ${HAS_G2D}; then
80 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini 83 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
81 fi 84 fi
82 85