summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-12-07 11:30:59 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2018-03-15 09:50:54 -0300
commitb6d3702140176f3fa78222ef33282c0d948faa50 (patch)
tree8c87103d7728f1df3d1c5eed1c70406a0f30d69e /recipes-graphics
parent3be3c2736231acb219feb6c00523f9a6f36d28ea (diff)
downloadmeta-freescale-b6d3702140176f3fa78222ef33282c0d948faa50.tar.gz
xf86-video-imxfb-vivante: Upgrade to 6.2.2.p0
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc14
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb (renamed from recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p8.6.bb)7
2 files changed, 10 insertions, 11 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
index e284fbce..c16da671 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
@@ -8,12 +8,14 @@ PE = "3"
8 8
9inherit autotools-brokensep update-rc.d pkgconfig 9inherit autotools-brokensep update-rc.d pkgconfig
10 10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman" 11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv virtual/libg2d pixman"
12 12
13LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3" 13LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3"
14 14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \ 15SRC_URI = "git://source.codeaurora.org/external/imx/xf86-video-imx-vivante.git;protocol=https;branch=${SRCBRANCH} \
16 file://rc.autohdmi" 16 file://rc.autohdmi"
17
18S = "${WORKDIR}/git/"
17 19
18INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi" 20INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
19INITSCRIPT_NAME = "rc.autohdmi" 21INITSCRIPT_NAME = "rc.autohdmi"
@@ -30,8 +32,6 @@ CFLAGS += "-I${STAGING_INCDIR}/xorg \
30 -I${STAGING_INCDIR}/drm \ 32 -I${STAGING_INCDIR}/drm \
31 -I../../DRI_1.10.4/src" 33 -I../../DRI_1.10.4/src"
32 34
33S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/"
34
35PACKAGES =+ "xserver-xorg-extension-viv-autohdmi" 35PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
36 36
37# FIXME: The Freescale provided Makefile has hardcodec include paths 37# FIXME: The Freescale provided Makefile has hardcodec include paths
@@ -53,7 +53,7 @@ do_install_append () {
53 find ${D}${includedir} -type f -exec chmod 660 {} \; 53 find ${D}${includedir} -type f -exec chmod 660 {} \;
54} 54}
55 55
56RDEPENDS_${PN} += "libvivante-dri-mx6 \ 56RDEPENDS_${PN} += "libvivante-dri-imx \
57 xserver-xorg-module-exa \ 57 xserver-xorg-module-exa \
58 mesa-driver-swrast \ 58 mesa-driver-swrast \
59 xserver-xorg-extension-dri \ 59 xserver-xorg-extension-dri \
@@ -70,4 +70,4 @@ FILES_${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIB
70FILES_xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi" 70FILES_xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
71 71
72PACKAGE_ARCH = "${MACHINE_SOCARCH}" 72PACKAGE_ARCH = "${MACHINE_SOCARCH}"
73COMPATIBLE_MACHINE = "(mx6)" 73COMPATIBLE_MACHINE = "(mx6|mx7ulp)"
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p8.6.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb
index 91456f22..5514962f 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p8.6.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_6.2.2.p0.bb
@@ -1,10 +1,9 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA. 2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Copyright 2017 NXP
3# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
4 5
5require xf86-video-imxfb-vivante.inc 6require xf86-video-imxfb-vivante.inc
6 7
7SRC_URI += "file://Stop-using-Git-to-write-local-version.patch" 8SRCBRANCH = "nxp/imx_4.9.11_1.0.0_ga"
8 9SRCREV = "07ef065dfe09f1c05a1a188c371577faa3677a17"
9SRC_URI[md5sum] = "8acbdddd51c9b1b0fd25137eeabd786d"
10SRC_URI[sha256sum] = "3eed38193e31bb5ba8d2c817bd9b4f6e2fe7540d2cab36de9098cb4f11946a9f"