summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-04-24 11:04:55 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-04-24 16:17:06 -0700
commitb1a6da98d63849df18628160d268c6a9b1521702 (patch)
treeabe01da37fa6eba90d8e965a1c51b6c9ed62e089 /recipes-graphics
parent21faf768fb4753614f48c06f9af9ebf1402ccd02 (diff)
downloadmeta-freescale-b1a6da98d63849df18628160d268c6a9b1521702.tar.gz
imx-dpu-g2d: Upgrade 2.1.10 -> 2.1.12
Adds a separate package for i.MX 95 support. Align with NXP BSP 6.6.3-1.0.0. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.10.bb38
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.12.bb45
2 files changed, 45 insertions, 38 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.10.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.10.bb
deleted file mode 100644
index 16011bd4..00000000
--- a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.10.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
8
9DEPENDS = "libgal-imx libdrm"
10PROVIDES += "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;fsl-eula=true"
13IMX_BIN_NAME = "${BP}-${IMX_SRCREV_ABBREV}"
14IMX_SRCREV_ABBREV = "7ed5396"
15SRC_URI[md5sum] = "eed4f724973192564474efbda83f67bc"
16SRC_URI[sha256sum] = "bca725e442c1438990cf1b41a59194e6efbd080c63d9b683a0d572e27f900e25"
17
18S = "${WORKDIR}/${IMX_BIN_NAME}"
19
20inherit fsl-eula-unpack
21
22do_install () {
23 install -d ${D}${libdir}
24 install -d ${D}${includedir}
25 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
26 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
27}
28
29INSANE_SKIP:append:libc-musl = " file-rdeps"
30RDEPENDS:${PN}:append:libc-musl = " gcompat"
31
32# The packaged binaries have been stripped of debug info, so disable
33# operations accordingly.
34INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
35INHIBIT_PACKAGE_STRIP = "1"
36INHIBIT_SYSROOT_STRIP = "1"
37
38COMPATIBLE_MACHINE = "(imxdpu)"
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.12.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.12.bb
new file mode 100644
index 00000000..b10cd997
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.12.bb
@@ -0,0 +1,45 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2024 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
8
9DEPENDS = "libdrm ${LIBGAL_IMX}"
10LIBGAL_IMX = "libgal-imx"
11LIBGAL_IMX:mx95-nxp-bsp = ""
12
13PROVIDES += "virtual/libg2d"
14
15SRC_URI = "${FSL_MIRROR}/${IMX_BIN_NAME}.bin;fsl-eula=true;name=${IMX_SRC_URI_NAME}"
16IMX_BIN_NAME = "${BPN}-${IMX_SRC_URI_NAME}-${PV}-${IMX_SRCREV_ABBREV}"
17
18IMX_SRCREV_ABBREV = "ee47ef7"
19IMX_SRC_URI_NAME = "v1"
20SRC_URI[v1.md5sum] = "4150f09e27178101fdccb792b7cbc526"
21SRC_URI[v1.sha256sum] = "bd7849376564f7e2eb55210f156afae00b49451de6de80cfbc5fbda15be6a2b0"
22
23IMX_SRCREV_ABBREV:mx95-nxp-bsp = "ee47ef7"
24IMX_SRC_URI_NAME:mx95-nxp-bsp = "v2"
25SRC_URI[v2.md5sum] = "031396e175c432eb6c84aad8e0a6fc7d"
26SRC_URI[v2.sha256sum] = "0646d8cc8e53f22fc15a61f0b78cd5f73460520f91949bc1d29c10ecbf77307b"
27
28S = "${WORKDIR}/${IMX_BIN_NAME}"
29
30inherit fsl-eula-unpack
31
32do_install () {
33 install -d ${D}${libdir}
34 install -d ${D}${includedir}
35 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
36 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
37}
38
39# The packaged binaries have been stripped of debug info, so disable
40# operations accordingly.
41INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
42INHIBIT_PACKAGE_STRIP = "1"
43INHIBIT_SYSROOT_STRIP = "1"
44
45COMPATIBLE_MACHINE = "(imxdpu)"