summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-01-16 13:52:26 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-23 16:55:31 -0200
commitafa03c974b95026219aadc8440d44bf05c26757d (patch)
tree4a3bc9f2b6283cd95c7e689ea11285af808b85e2 /recipes-graphics
parent599f72c34c826142ed56c41261163f795dcdfa18 (diff)
downloadmeta-freescale-afa03c974b95026219aadc8440d44bf05c26757d.tar.gz
weston: Touch events cause startup failure
Pressing the touch panel continously during boot up caused weston to crash. The weston view was being accessed before it was fully initialized, so now we guard against this. Upstream-Status: Denied [Could not reproduce] Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/0019-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch44
-rw-r--r--recipes-graphics/wayland/weston/0020-xwayland-Fix-crash-when-run-with-no-input-device.patch (renamed from recipes-graphics/wayland/weston/0019-xwayland-Fix-crash-when-run-with-no-input-device.patch)0
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend3
3 files changed, 46 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston/0019-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch b/recipes-graphics/wayland/weston/0019-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch
new file mode 100644
index 00000000..09404caf
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0019-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch
@@ -0,0 +1,44 @@
1From d3bc23ef2031e2749362bb0b90e5d164ef5d5942 Mon Sep 17 00:00:00 2001
2From: Meng Mingming <mingming.meng@nxp.com>
3Date: Mon, 9 Jan 2017 15:08:51 +0800
4Subject: [PATCH 4/6] MGS-1668: xwld: System can not boot up to desktop
5
6System can not boot up to desktop if press touch panel continuously during booting up.
7The weston view was not initialed completely, so add a protection to the pointer.
8
9Upstream Status: Inappropriate [i.MX specific]
10
11Date: MAR 08, 2016
12Signed-off-by: Yong Gan <yong.gan@nxp.com>
13---
14 src/compositor.c | 14 ++++++++------
15 1 file changed, 8 insertions(+), 6 deletions(-)
16
17diff --git a/src/compositor.c b/src/compositor.c
18index b6ef7f3..9d9805d 100644
19--- a/src/compositor.c
20+++ b/src/compositor.c
21@@ -1470,12 +1470,14 @@ weston_view_from_global_fixed(struct weston_view *view,
22 {
23 float vxf, vyf;
24
25- weston_view_from_global_float(view,
26- wl_fixed_to_double(x),
27- wl_fixed_to_double(y),
28- &vxf, &vyf);
29- *vx = wl_fixed_from_double(vxf);
30- *vy = wl_fixed_from_double(vyf);
31+ if(view != NULL) {
32+ weston_view_from_global_float(view,
33+ wl_fixed_to_double(x),
34+ wl_fixed_to_double(y),
35+ &vxf, &vyf);
36+ *vx = wl_fixed_from_double(vxf);
37+ *vy = wl_fixed_from_double(vyf);
38+ }
39 }
40
41 WL_EXPORT void
42--
432.7.4
44
diff --git a/recipes-graphics/wayland/weston/0019-xwayland-Fix-crash-when-run-with-no-input-device.patch b/recipes-graphics/wayland/weston/0020-xwayland-Fix-crash-when-run-with-no-input-device.patch
index 1304cef2..1304cef2 100644
--- a/recipes-graphics/wayland/weston/0019-xwayland-Fix-crash-when-run-with-no-input-device.patch
+++ b/recipes-graphics/wayland/weston/0020-xwayland-Fix-crash-when-run-with-no-input-device.patch
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index dfd7da44..26b12dcd 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -17,10 +17,11 @@ SRC_URI_append_imxgpu3d = " \
17 file://0016-Link-compositor-to-egl.patch \ 17 file://0016-Link-compositor-to-egl.patch \
18 file://0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch \ 18 file://0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch \
19 file://0018-MGS-2397-ccc-Enable-double-buffer-with-fb_pan_displa.patch \ 19 file://0018-MGS-2397-ccc-Enable-double-buffer-with-fb_pan_displa.patch \
20 file://0019-MGS-1668-xwld-System-can-not-boot-up-to-desktop.patch \
20" 21"
21 22
22SRC_URI_append = " \ 23SRC_URI_append = " \
23 file://0019-xwayland-Fix-crash-when-run-with-no-input-device.patch \ 24 file://0020-xwayland-Fix-crash-when-run-with-no-input-device.patch \
24" 25"
25 26
26# The 'egl' configuration of weston requires gles support, and consideration 27# The 'egl' configuration of weston requires gles support, and consideration