summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-12-13 11:55:45 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2016-12-16 17:01:24 -0200
commit6ec09e6a0f09d1cb9c3761b339590c0a0baeeeb3 (patch)
tree74ce89b4ed734dec33c3a045fb18d273494352a9 /recipes-graphics
parenta3c82c56f4deaf3315be023d4d5f8b0a72f7357c (diff)
downloadmeta-freescale-6ec09e6a0f09d1cb9c3761b339590c0a0baeeeb3.tar.gz
weston: Add egl and gles support for non-GPU SoCs
For SoCs with no GPU, configure weston to use the software versions of egl and gles through mesa. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index f7b12d0b..b78a299a 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -17,10 +17,18 @@ SRC_URI_append_imxgpu3d = " \
17 file://0016-Link-compositor-to-egl.patch \ 17 file://0016-Link-compositor-to-egl.patch \
18" 18"
19 19
20# The 'egl' configuration of weston requires gles support, and consideration
21# must be taken for the different SoC capabilities:
22# - For SoCs with 3d support, imx-gpu-viv provides hardware-accelerated
23# egl and gles, so weston egl configuration is enabled.
24# - For SoCs with VG2D, like i.MX 6SoloLite, imx-gpu-viv provides
25# hardware-accelerated egl but does not provide a compatible software
26# version of gles, so weston egl configuration is disabled.
27# - For SoCs with no GPU, mesa provides software implementations of egl
28# and gles, so weston egl configuration is enabled.
20PACKAGECONFIG_IMX_TO_APPEND = "" 29PACKAGECONFIG_IMX_TO_APPEND = ""
21PACKAGECONFIG_IMX_TO_APPEND_imxgpu3d = "cairo-glesv2" 30PACKAGECONFIG_IMX_TO_APPEND_imxgpu3d = "cairo-glesv2"
22PACKAGECONFIG_IMX_TO_REMOVE = "" 31PACKAGECONFIG_IMX_TO_REMOVE = ""
23PACKAGECONFIG_IMX_TO_REMOVE_imxpxp = "egl"
24PACKAGECONFIG_IMX_TO_REMOVE_imxgpu2d = "egl" 32PACKAGECONFIG_IMX_TO_REMOVE_imxgpu2d = "egl"
25PACKAGECONFIG_IMX_TO_REMOVE_imxgpu3d = "" 33PACKAGECONFIG_IMX_TO_REMOVE_imxgpu3d = ""
26 34