summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-04-24 09:20:50 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-04-24 16:16:52 -0700
commit364fa4a6416758ae8c47f3165336caae6951fe36 (patch)
tree3063ded03f07080bdafde21f05205550f7b7a389 /recipes-graphics
parentdac97d19df2e68fc375a0fc235a7530b0aa199c8 (diff)
downloadmeta-freescale-364fa4a6416758ae8c47f3165336caae6951fe36.tar.gz
imx-gpu-viv: Upgrade 6.4.11.p2.2 -> 6.4.11.p2.4
Drops OpenGL support. Align with NXP BSP 6.6.3-1.0.0. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc22
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch32.bb10
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch64.bb10
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch32.bb10
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch64.bb10
-rw-r--r--recipes-graphics/mesa/mesa-gl_%.bbappend9
6 files changed, 30 insertions, 41 deletions
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index 56a9ec4d..e33df444 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -1,6 +1,6 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright (C) 2012-2018 O.S. Systems Software LTDA. 2# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
3# Copyright 2017-2023 NXP 3# Copyright 2017-2024 NXP
4# Released under the MIT license (see COPYING.MIT for the terms) 4# Released under the MIT license (see COPYING.MIT for the terms)
5 5
6DESCRIPTION = "GPU driver and apps for i.MX" 6DESCRIPTION = "GPU driver and apps for i.MX"
@@ -20,11 +20,6 @@ DEPENDS += " \
20DEPENDS:append:imxdrm = " libdrm wayland" 20DEPENDS:append:imxdrm = " libdrm wayland"
21DEPENDS:append:mx8-nxp-bsp = " patchelf-native" 21DEPENDS:append:mx8-nxp-bsp = " patchelf-native"
22 22
23# imx-gpu-viv does not provide everything it needs to for virtual/libgl
24# on x11 backend or on Wayland backend with XWayland support.
25# We depend on mesa to fill in what is missing.
26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa', '', d)}"
27
28DEPENDS:append:libc-musl = " gcompat" 23DEPENDS:append:libc-musl = " gcompat"
29 24
30PROVIDES += " \ 25PROVIDES += " \
@@ -40,7 +35,6 @@ EXTRA_PROVIDES = " \
40 ${PROVIDES_OPENVX} \ 35 ${PROVIDES_OPENVX} \
41" 36"
42EXTRA_PROVIDES:append:imxgpu3d = " \ 37EXTRA_PROVIDES:append:imxgpu3d = " \
43 virtual/libgl \
44 virtual/libgles1 \ 38 virtual/libgles1 \
45 virtual/libgles2 \ 39 virtual/libgles2 \
46" 40"
@@ -86,7 +80,6 @@ PACKAGECONFIG[valgrind] = ""
86 80
87# Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below 81# Note : If you add a package here, to prevent a naming conflict see the python_anonymous() futher below
88PACKAGES =+ " \ 82PACKAGES =+ " \
89 libgl-imx libgl-imx-dev \
90 libgles1-imx libgles1-imx-dev \ 83 libgles1-imx libgles1-imx-dev \
91 libgles2-imx libgles2-imx-dev \ 84 libgles2-imx libgles2-imx-dev \
92 libgles3-imx-dev \ 85 libgles3-imx-dev \
@@ -149,7 +142,7 @@ python __anonymous() {
149 142
150 # For the packages that make up the OpenGL interfaces, inject variables so that 143 # For the packages that make up the OpenGL interfaces, inject variables so that
151 # they don't get Debian-renamed (which would remove the -imx suffix). 144 # they don't get Debian-renamed (which would remove the -imx suffix).
152 for p in (("libegl", "libegl1"), ("libgl", "libgl1"), 145 for p in (("libegl", "libegl1"),
153 ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"), 146 ("libgles1", "libglesv1-cm1"), ("libgles2", "libglesv2-2"),
154 ("libgles3",), ("libgbm",)): 147 ("libgles3",), ("libgbm",)):
155 fullp = p[0] + "-imx" 148 fullp = p[0] + "-imx"
@@ -291,8 +284,6 @@ do_install () {
291 if [ "${IS_MX6SL}" = "1" ]; then 284 if [ "${IS_MX6SL}" = "1" ]; then
292 rm -rf ${D}${libdir}/libCLC* ${D}${includedir}/CL \ 285 rm -rf ${D}${libdir}/libCLC* ${D}${includedir}/CL \
293 \ 286 \
294 ${D}${libdir}/libGL* ${D}${includedir}/GL* ${D}${libdir}/pkgconfig/gl.pc \
295 \
296 ${D}${libdir}/libGLES* ${D}${libdir}/pkgconfig/gles*.pc \ 287 ${D}${libdir}/libGLES* ${D}${libdir}/pkgconfig/gles*.pc \
297 \ 288 \
298 ${D}${libdir}/libOpenCL* ${D}${includedir}/CL \ 289 ${D}${libdir}/libOpenCL* ${D}${includedir}/CL \
@@ -377,15 +368,6 @@ OPENCL_VX_INTRINSIC_EXTENSION_PACKAGES:mx8qm-nxp-bsp = "libclc-imx libopencl-imx
377OPENCL_VX_INTRINSIC_EXTENSION_PACKAGES:mx8mp-nxp-bsp = "libclc-imx libopencl-imx-dev" 368OPENCL_VX_INTRINSIC_EXTENSION_PACKAGES:mx8mp-nxp-bsp = "libclc-imx libopencl-imx-dev"
378INSANE_SKIP:libopenvx-imx += "dev-deps" 369INSANE_SKIP:libopenvx-imx += "dev-deps"
379 370
380FILES:libgl-imx = "${libdir}/libGL${REALSOLIBS} ${libdir}/libGL${SOLIBS}"
381FILES:libgl-imx-dev = "${includedir}/GL ${libdir}/pkgconfig/gl.pc"
382# libGL is only targeting X11 backend, and in case if Wayland-only is used -
383# package QA complains on missing RDEPENDS, which are only available for X11.
384# Skip "file-rdeps" QA for this package.
385INSANE_SKIP:libgl-imx += "file-rdeps"
386# libEGL does dlopen of libGL.so
387INSANE_SKIP:libgl-imx += "dev-so"
388
389FILES:libgles1-imx = "${libdir}/libGLESv1*${REALSOLIBS} ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${REALSOLIBS} ${libdir}/libGLES_*${SOLIBS}" 371FILES:libgles1-imx = "${libdir}/libGLESv1*${REALSOLIBS} ${libdir}/libGLESv1*${SOLIBS} ${libdir}/libGLES_*${REALSOLIBS} ${libdir}/libGLES_*${SOLIBS}"
390FILES:libgles1-imx-dev = "${includedir}/GLES ${libdir}/pkgconfig/glesv1_cm.pc" 372FILES:libgles1-imx-dev = "${includedir}/GLES ${libdir}/pkgconfig/glesv1_cm.pc"
391RPROVIDES:libgles1-imx = "libgles-imx" 373RPROVIDES:libgles1-imx = "libgles-imx"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch32.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch32.bb
deleted file mode 100644
index 07a92246..00000000
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch32.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require imx-gpu-viv-6.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=2827219e81f28aba7c6a569f7c437fa7"
4
5IMX_SRCREV_ABBREV = "fd0148d"
6
7SRC_URI[md5sum] = "267d3e2d580e264157b7de01df22fb66"
8SRC_URI[sha256sum] = "15efe6da5d4bac2a6067c2a898190be8754df6f14128c3db4756cff59c6da049"
9
10COMPATIBLE_MACHINE = "(mx6q-nxp-bsp|mx6dl-nxp-bsp|mx6sx-nxp-bsp|mx6sl-nxp-bsp|mx7ulp-nxp-bsp)"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch64.bb
deleted file mode 100644
index cea83ddc..00000000
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.2-aarch64.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require imx-gpu-viv-6.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=2827219e81f28aba7c6a569f7c437fa7"
4
5IMX_SRCREV_ABBREV = "fd0148d"
6
7SRC_URI[md5sum] = "b76784e04f24ec9f2bedf2dd377ed5a8"
8SRC_URI[sha256sum] = "6e34f3718925ba37c362cd09a3228cc56d03cfad323ebae0932f64449dbaeb2e"
9
10COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch32.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch32.bb
new file mode 100644
index 00000000..2b172466
--- /dev/null
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch32.bb
@@ -0,0 +1,10 @@
1require imx-gpu-viv-6.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
4
5IMX_SRCREV_ABBREV = "b07999b"
6
7SRC_URI[md5sum] = "eae60321ac971293d3213c88b9198ca0"
8SRC_URI[sha256sum] = "ef9be89d3dd3b6448c720e061a8b81bdd26f7a5ff70de1786a5feef2e4836474"
9
10COMPATIBLE_MACHINE = "(mx6q-nxp-bsp|mx6dl-nxp-bsp|mx6sx-nxp-bsp|mx6sl-nxp-bsp|mx7ulp-nxp-bsp)"
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch64.bb b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch64.bb
new file mode 100644
index 00000000..b3c39736
--- /dev/null
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv_6.4.11.p2.4-aarch64.bb
@@ -0,0 +1,10 @@
1require imx-gpu-viv-6.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
4
5IMX_SRCREV_ABBREV = "b07999b"
6
7SRC_URI[md5sum] = "142d9b9ef6f440b8e307569873bdb6b5"
8SRC_URI[sha256sum] = "ba86656c357c5d9793058695f320e4cf650d4693e84321870bad392f2a622807"
9
10COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend
index dafd27f0..6545571f 100644
--- a/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1 +1,8 @@
1COMPATIBLE_MACHINE:imxgpu = "(-)" 1DEPENDS:append:imxgpu = " virtual/egl"
2
3do_install:append:imxgpu() {
4 # imx-gpu-viv and mali-imx both provide /usr/include/KHR, so drop the mesa-gl one
5 rm -rf ${D}${includedir}/KHR
6}
7
8COMPATIBLE_MACHINE:imxgpu = "(imxgpu)"