summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-01-16 13:52:22 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-23 16:55:31 -0200
commit1d4e45fff88b8fd43681e31dc30b1edff3fa0c10 (patch)
tree722231c92a26bdff650dc4614e5e41b664f6cb31 /recipes-graphics
parent68107cf237c189d74fa9b2a2815a6b2a3c211225 (diff)
downloadmeta-freescale-1d4e45fff88b8fd43681e31dc30b1edff3fa0c10.tar.gz
weston: T3DStressTest_Wayland displays abnormally while using G2D compositor
It need add g2d_finish after repaint_region and before copy to framebuffer. Because if using dual dpu cores, the tasks on each core will be executed sequently, but it can't ensure one task splited on dual cores can be finished synchronously by hardware. Upstream-Status: Inappropriate [i.MX specific] Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch40
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend1
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston/0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch b/recipes-graphics/wayland/weston/0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch
new file mode 100644
index 00000000..d0b82aa4
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch
@@ -0,0 +1,40 @@
1From 0cc335a411127feb05e16cbf2803058b2db1b405 Mon Sep 17 00:00:00 2001
2From: Meng Mingming <mingming.meng@nxp.com>
3Date: Thu, 27 Oct 2016 17:00:24 +0800
4Subject: [PATCH 1/2] MGS-2343 [#ccc] XWLD: T3DStressTest_Wayland displays
5 abnormally while using G2D compositor
6
7It need add g2d_finish after repaint_region and before copy to framebuffer.
8Because if using dual dpu cores, the tasks on each core will be executed
9sequently, but it can't ensure one task splited on dual cores can be finished
10synchronously by hardware.
11
12Upstream-Status: Inappropriate [i.MX specific]
13
14Date: Oct 27, 2016
15Signed-off-by: Meng Mingming <mingming.meng@nxp.com>
16---
17 src/g2d-renderer.c | 1 +
18 1 file changed, 1 insertion(+)
19
20Index: weston-1.11.0/src/g2d-renderer.c
21===================================================================
22--- weston-1.11.0.orig/src/g2d-renderer.c 2017-01-12 14:58:11.923607788 -0600
23+++ weston-1.11.0/src/g2d-renderer.c 2017-01-12 18:08:33.328243476 -0600
24@@ -679,6 +679,8 @@
25 pixman_region32_t *output_damage)
26 {
27 struct g2d_output_state *go = get_output_state(output);
28+ struct weston_compositor *compositor = output->compositor;
29+ struct g2d_renderer *gr = get_renderer(compositor);
30 int i;
31
32 use_output(output);
33@@ -691,6 +693,7 @@
34 &go->buffer_damage[go->current_buffer]);
35
36 repaint_views(output, output_damage);
37+ g2d_finish(gr->handle);
38
39 pixman_region32_copy(&output->previous_damage, output_damage);
40 wl_signal_emit(&output->frame_signal, output);
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index b78a299a..aa13f27d 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -15,6 +15,7 @@ SRC_URI_append_imxgpu3d = " \
15 file://0014-MGS-1987-Get-stride-from-the-FB-buffe.patch \ 15 file://0014-MGS-1987-Get-stride-from-the-FB-buffe.patch \
16 file://0015-MGS-2221-imx-171-Fix-weston-build-failed.patch \ 16 file://0015-MGS-2221-imx-171-Fix-weston-build-failed.patch \
17 file://0016-Link-compositor-to-egl.patch \ 17 file://0016-Link-compositor-to-egl.patch \
18 file://0017-MGS-2343-ccc-XWLD-T3DStressTest_Wayland-displays-abn.patch \
18" 19"
19 20
20# The 'egl' configuration of weston requires gles support, and consideration 21# The 'egl' configuration of weston requires gles support, and consideration