summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-12-07 11:30:56 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2018-03-15 09:50:54 -0300
commit0b2b66d5974fc9835f9cd71bbcced187cd27f97c (patch)
tree8aecbbe6f9001d48c3f9cd80492f64f31e7dca07 /recipes-graphics
parent875480839bd748c028f55cd39dcaf88e6249905b (diff)
downloadmeta-freescale-0b2b66d5974fc9835f9cd71bbcced187cd27f97c.tar.gz
imx-gpu-g2d: Move imx-gpu-g2d out of imx-gpu-viv v6
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
new file mode 100644
index 00000000..8be05f93
--- /dev/null
+++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.2.p0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "GPU G2D library and apps for imx6"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671"
8
9PROVIDES += "virtual/libg2d"
10
11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
12
13S="${WORKDIR}/${PN}-${PV}"
14
15inherit fsl-eula-unpack
16
17SRC_URI[md5sum] = "64720dda9b96fd7af5be7e2c654ab72a"
18SRC_URI[sha256sum] = "070a95aa9942bd67e8ba4012962df74143bffb9998301ac097dab5e1437000d8"
19
20do_install () {
21
22 install -d ${D}${libdir}
23 install -d ${D}${includedir}
24
25 cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
26 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
27 cp -r ${S}/gpu-demos/opt ${D}
28}
29
30RDEPENDS_${PN} = "libgal-imx"
31
32FILES_${PN} = "${libdir}/libg2d* /opt"
33FILES_${PN}-dev = "${includedir}"
34INSANE_SKIP_${PN} = "ldflags"
35
36COMPATIBLE_MACHINE = "(mx6|mx7ulp)"