summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-06-25 21:11:37 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-05 15:32:27 -0300
commit08d037b0ace4c71ae77b5e4bc6d990252995cf91 (patch)
treec279739e26e1ad4126249c532c26e368d7346482 /recipes-graphics
parent433a85c877765b62bd5c480be212c5df30680cd6 (diff)
downloadmeta-freescale-08d037b0ace4c71ae77b5e4bc6d990252995cf91.tar.gz
weston: Remove 2.0 recipe
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/0001-configure.ac-Fix-wayland-protocols-path.patch29
-rw-r--r--recipes-graphics/wayland/weston/0001-make-error-portable.patch70
-rw-r--r--recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch174
-rw-r--r--recipes-graphics/wayland/weston/weston.desktop9
-rw-r--r--recipes-graphics/wayland/weston/weston.pngbin2383 -> 0 bytes
-rw-r--r--recipes-graphics/wayland/weston/xwayland.weston-start7
-rw-r--r--recipes-graphics/wayland/weston_2.0.0.bb113
-rw-r--r--recipes-graphics/wayland/weston_2.0.0.bbappend36
8 files changed, 0 insertions, 438 deletions
diff --git a/recipes-graphics/wayland/weston/0001-configure.ac-Fix-wayland-protocols-path.patch b/recipes-graphics/wayland/weston/0001-configure.ac-Fix-wayland-protocols-path.patch
deleted file mode 100644
index 5f4d79c3..00000000
--- a/recipes-graphics/wayland/weston/0001-configure.ac-Fix-wayland-protocols-path.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 1cfc1434a5d385a74de593ec7601674dba39e2fe Mon Sep 17 00:00:00 2001
2From: Jussi Kukkonen <jussi.kukkonen@intel.com>
3Date: Wed, 11 May 2016 16:16:30 +0300
4Subject: [PATCH] configure.ac: Fix wayland-protocols path
5
6The wayland-protocols directory is used during build: Fix the path
7to point to sysroot specified in recipe.
8
9Normally PKG_CONFIG_SYSROOT_DIR could be used in configure.ac but that
10breaks multilib weston as it would point to multilib sysroot when the
11(allarch) wayland-protocols is actually in the machine sysroot.
12
13Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
14Upstream-Status: Inappropriate [embedded specific]
15---
16 configure.ac | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19--- a/configure.ac
20+++ b/configure.ac
21@@ -187,7 +187,7 @@ PKG_CHECK_MODULES(LIBINPUT_BACKEND, [lib
22 PKG_CHECK_MODULES(COMPOSITOR, [$COMPOSITOR_MODULES])
23
24 PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.7],
25- [ac_wayland_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
26+ [ac_wayland_protocols_pkgdatadir=${WAYLAND_PROTOCOLS_SYSROOT_DIR}`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
27 AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, $ac_wayland_protocols_pkgdatadir)
28
29 AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
diff --git a/recipes-graphics/wayland/weston/0001-make-error-portable.patch b/recipes-graphics/wayland/weston/0001-make-error-portable.patch
deleted file mode 100644
index e2213aca..00000000
--- a/recipes-graphics/wayland/weston/0001-make-error-portable.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1From c22e90365d89346258394833cbcad03ff32b2e27 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 29 May 2015 20:56:00 -0700
4Subject: [PATCH weston] make error() portable
5
6error() is not posix but gnu extension so may not be available on all
7kind of systemsi e.g. musl.
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11Upstream-Status: Submitted
12
13 configure.ac | 2 ++
14 libweston/weston-error.h | 20 ++++++++++++++++++++
15 libweston/weston-launch.c | 2 +-
16 3 files changed, 23 insertions(+), 1 deletion(-)
17 create mode 100644 src/weston-error.h
18
19--- a/configure.ac
20+++ b/configure.ac
21@@ -60,6 +60,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
22 [[#include <time.h>]])
23 AC_CHECK_HEADERS([execinfo.h])
24
25+AC_CHECK_HEADERS([error.h])
26+
27 AC_CHECK_FUNCS([mkostemp strchrnul initgroups posix_fallocate])
28
29 COMPOSITOR_MODULES="wayland-server >= $WAYLAND_PREREQ_VERSION pixman-1 >= 0.25.2"
30--- /dev/null
31+++ b/libweston/weston-error.h
32@@ -0,0 +1,20 @@
33+#ifndef _WESTON_ERROR_H
34+#define _WESTON_ERROR_H
35+
36+#if defined(HAVE_ERROR_H)
37+#include <error.h>
38+#else
39+#include <err.h>
40+#include <string.h>
41+#define _weston_error(S, E, F, ...) do { \
42+ if (E) \
43+ err(S, F ": %s", ##__VA_ARGS__, strerror(E)); \
44+ else \
45+ err(S, F, ##__VA_ARGS__); \
46+} while(0)
47+
48+#define error _weston_error
49+#endif
50+
51+#endif
52+
53--- a/libweston/weston-launch.c
54+++ b/libweston/weston-launch.c
55@@ -33,7 +33,6 @@
56 #include <poll.h>
57 #include <errno.h>
58
59-#include <error.h>
60 #include <getopt.h>
61
62 #include <sys/types.h>
63@@ -59,6 +58,7 @@
64 #endif
65
66 #include "weston-launch.h"
67+#include "weston-error.h"
68
69 #define DRM_MAJOR 226
70
diff --git a/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch b/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
deleted file mode 100644
index 70b98889..00000000
--- a/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
+++ /dev/null
@@ -1,174 +0,0 @@
1From 8ff6ed03ec4079f32e9b34085414e57be4730e04 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Feb 2017 15:53:30 +0200
4Subject: [PATCH] weston-launch: Provide a default version that doesn't require
5 PAM
6
7weston-launch requires PAM for starting weston as a non-root user.
8
9Since starting weston as root is a valid use case by itself, if
10PAM is not available, provide a default version of weston-launch
11without non-root-user support.
12
13Upstream-Status: Pending
14
15Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
16Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
17---
18 configure.ac | 9 +++++++--
19 libweston/weston-launch.c | 20 ++++++++++++++++++++
20 2 files changed, 27 insertions(+), 2 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index 46cb2c7..bb45f46 100644
24--- a/configure.ac
25+++ b/configure.ac
26@@ -435,13 +435,17 @@ AC_ARG_ENABLE(resize-optimization,
27 AS_IF([test "x$enable_resize_optimization" = "xyes"],
28 [AC_DEFINE([USE_RESIZE_POOL], [1], [Use resize memory pool as a performance optimization])])
29
30+AC_ARG_WITH(pam,
31+ AS_HELP_STRING([--with-pam], [Use PAM]),
32+ [use_pam=$withval], [use_pam=yes])
33 AC_ARG_ENABLE(weston-launch, [ --enable-weston-launch],, enable_weston_launch=yes)
34 AM_CONDITIONAL(BUILD_WESTON_LAUNCH, test x$enable_weston_launch = xyes)
35-if test x$enable_weston_launch = xyes; then
36+if test x$enable_weston_launch = xyes -a x$use_pam = xyes; then
37 WESTON_SEARCH_LIBS([PAM], [pam], [pam_open_session], [have_pam=yes], [have_pam=no])
38 if test x$have_pam = xno; then
39- AC_ERROR([weston-launch requires pam])
40+ AC_ERROR([PAM support is explicitly requested, but libpam couldn't be found])
41 fi
42+ AC_DEFINE([HAVE_PAM], [1], [Define if PAM is available])
43 fi
44
45 AM_CONDITIONAL(HAVE_PANGO, test "x$have_pango" = "xyes")
46@@ -701,6 +705,7 @@ AC_MSG_RESULT([
47 Enable developer documentation ${enable_devdocs}
48
49 weston-launch utility ${enable_weston_launch}
50+ PAM support ${use_pam}
51 systemd-login support ${have_systemd_login}
52 systemd notify support ${enable_systemd_notify}
53
54diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c
55index 0491896..07e7469 100644
56--- a/libweston/weston-launch.c
57+++ b/libweston/weston-launch.c
58@@ -51,7 +51,9 @@
59
60 #include <pwd.h>
61 #include <grp.h>
62+#ifdef HAVE_PAM
63 #include <security/pam_appl.h>
64+#endif
65
66 #ifdef HAVE_SYSTEMD_LOGIN
67 #include <systemd/sd-login.h>
68@@ -93,8 +95,10 @@ drmSetMaster(int drm_fd)
69 #endif
70
71 struct weston_launch {
72+#ifdef HAVE_PAM
73 struct pam_conv pc;
74 pam_handle_t *ph;
75+#endif
76 int tty;
77 int ttynr;
78 int sock[2];
79@@ -181,6 +185,7 @@ weston_launch_allowed(struct weston_launch *wl)
80 return false;
81 }
82
83+#ifdef HAVE_PAM
84 static int
85 pam_conversation_fn(int msg_count,
86 const struct pam_message **messages,
87@@ -221,6 +226,7 @@ setup_pam(struct weston_launch *wl)
88
89 return 0;
90 }
91+#endif
92
93 static int
94 setup_launcher_socket(struct weston_launch *wl)
95@@ -414,6 +420,7 @@ quit(struct weston_launch *wl, int status)
96 close(wl->signalfd);
97 close(wl->sock[0]);
98
99+#ifdef HAVE_PAM
100 if (wl->new_user) {
101 err = pam_close_session(wl->ph, 0);
102 if (err)
103@@ -421,6 +428,7 @@ quit(struct weston_launch *wl, int status)
104 err, pam_strerror(wl->ph, err));
105 pam_end(wl->ph, err);
106 }
107+#endif
108
109 if (ioctl(wl->tty, KDSKBMUTE, 0) &&
110 ioctl(wl->tty, KDSKBMODE, wl->kb_mode))
111@@ -600,6 +608,7 @@ setup_session(struct weston_launch *wl, char **child_argv)
112 setenv("HOME", wl->pw->pw_dir, 1);
113 setenv("SHELL", wl->pw->pw_shell, 1);
114
115+#ifdef HAVE_PAM
116 env = pam_getenvlist(wl->ph);
117 if (env) {
118 for (i = 0; env[i]; ++i) {
119@@ -608,6 +617,7 @@ setup_session(struct weston_launch *wl, char **child_argv)
120 }
121 free(env);
122 }
123+#endif
124
125 /*
126 * We open a new session, so it makes sense
127@@ -675,7 +685,9 @@ static void
128 help(const char *name)
129 {
130 fprintf(stderr, "Usage: %s [args...] [-- [weston args..]]\n", name);
131+#ifdef HAVE_PAM
132 fprintf(stderr, " -u, --user Start session as specified username\n");
133+#endif
134 fprintf(stderr, " -t, --tty Start session on alternative tty\n");
135 fprintf(stderr, " -v, --verbose Be verbose\n");
136 fprintf(stderr, " -h, --help Display this help message\n");
137@@ -688,7 +700,9 @@ main(int argc, char *argv[])
138 int i, c;
139 char *tty = NULL;
140 struct option opts[] = {
141+#ifdef HAVE_PAM
142 { "user", required_argument, NULL, 'u' },
143+#endif
144 { "tty", required_argument, NULL, 't' },
145 { "verbose", no_argument, NULL, 'v' },
146 { "help", no_argument, NULL, 'h' },
147@@ -700,9 +714,13 @@ main(int argc, char *argv[])
148 while ((c = getopt_long(argc, argv, "u:t::vh", opts, &i)) != -1) {
149 switch (c) {
150 case 'u':
151+#ifdef HAVE_PAM
152 wl.new_user = optarg;
153 if (getuid() != 0)
154 error(1, 0, "Permission denied. -u allowed for root only");
155+#else
156+ error(1, 0, "-u is unsupported in this weston-launch build");
157+#endif
158 break;
159 case 't':
160 tty = optarg;
161@@ -740,8 +758,10 @@ main(int argc, char *argv[])
162 if (setup_tty(&wl, tty) < 0)
163 exit(EXIT_FAILURE);
164
165+#ifdef HAVE_PAM
166 if (wl.new_user && setup_pam(&wl) < 0)
167 exit(EXIT_FAILURE);
168+#endif
169
170 if (setup_launcher_socket(&wl) < 0)
171 exit(EXIT_FAILURE);
172--
1732.1.4
174
diff --git a/recipes-graphics/wayland/weston/weston.desktop b/recipes-graphics/wayland/weston/weston.desktop
deleted file mode 100644
index 1086ae8b..00000000
--- a/recipes-graphics/wayland/weston/weston.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
1[Desktop Entry]
2Encoding=UTF-8
3Type=Application
4Name=Weston
5Comment=Wayland Compostitor
6Exec=weston
7Icon=weston
8Terminal=false
9Categories=Utility;
diff --git a/recipes-graphics/wayland/weston/weston.png b/recipes-graphics/wayland/weston/weston.png
deleted file mode 100644
index ea8b7e0e..00000000
--- a/recipes-graphics/wayland/weston/weston.png
+++ /dev/null
Binary files differ
diff --git a/recipes-graphics/wayland/weston/xwayland.weston-start b/recipes-graphics/wayland/weston/xwayland.weston-start
deleted file mode 100644
index b483c97c..00000000
--- a/recipes-graphics/wayland/weston/xwayland.weston-start
+++ /dev/null
@@ -1,7 +0,0 @@
1#!/bin/sh
2
3if type Xwayland >/dev/null 2>/dev/null; then
4 mkdir -p /tmp/.X11-unix
5
6 add_weston_argument "--modules=xwayland.so"
7fi
diff --git a/recipes-graphics/wayland/weston_2.0.0.bb b/recipes-graphics/wayland/weston_2.0.0.bb
deleted file mode 100644
index 8160f555..00000000
--- a/recipes-graphics/wayland/weston_2.0.0.bb
+++ /dev/null
@@ -1,113 +0,0 @@
1SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=26;md5=e342df749174a8ee11065583157c7a38"
7
8SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://weston.png \
10 file://weston.desktop \
11 file://0001-make-error-portable.patch \
12 file://0001-configure.ac-Fix-wayland-protocols-path.patch \
13 file://xwayland.weston-start \
14 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
15"
16SRC_URI[md5sum] = "15f38945942bf2a91fe2687145fb4c7d"
17SRC_URI[sha256sum] = "b4e446ac27f118196f1609dab89bb3cb3e81652d981414ad860e733b355365d8"
18
19inherit autotools pkgconfig useradd distro_features_check
20# depends on virtual/egl
21REQUIRED_DISTRO_FEATURES = "opengl"
22
23DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
24DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
25
26EXTRA_OECONF = "--enable-setuid-install \
27 --disable-rdp-compositor \
28 "
29EXTRA_OECONF_append_qemux86 = "\
30 WESTON_NATIVE_BACKEND=fbdev-backend.so \
31 "
32EXTRA_OECONF_append_qemux86-64 = "\
33 WESTON_NATIVE_BACKEND=fbdev-backend.so \
34 "
35PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \
38 clients launch"
39#
40# Compositor choices
41#
42# Weston on KMS
43PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev"
44# Weston on Wayland (nested Weston)
45PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
46# Weston on X11
47PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
48# Headless Weston
49PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor"
50# Weston on framebuffer
51PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
52# weston-launch
53PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm"
54# VA-API desktop recorder
55PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"
56# Weston with EGL support
57PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl"
58# Weston with cairo glesv2 support
59PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo"
60# Weston with lcms support
61PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
62# Weston with webp support
63PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
64# Weston with unwinding support
65PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
66# Weston with systemd-login support
67PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus"
68# Weston with Xwayland support (requires X11 and Wayland)
69PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland"
70# colord CMS support
71PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord"
72# Clients support
73PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients"
74# Weston with PAM support
75PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam"
76
77do_install_append() {
78 # Weston doesn't need the .la files to load modules, so wipe them
79 rm -f ${D}/${libdir}/libweston-2/*.la
80
81 # If X11, ship a desktop file to launch it
82 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
83 install -d ${D}${datadir}/applications
84 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
85
86 install -d ${D}${datadir}/icons/hicolor/48x48/apps
87 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
88 fi
89
90 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
91 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
92 fi
93}
94
95PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
96 libweston-2 ${PN}-examples"
97
98FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}"
99
100FILES_libweston-2 = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-2/*.so"
101SUMMARY_libweston-2 = "Helper library for implementing 'wayland window managers'."
102
103FILES_${PN}-examples = "${bindir}/*"
104
105FILES_${PN}-xwayland = "${libdir}/libweston-2/xwayland.so"
106RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland"
107
108RDEPENDS_${PN} += "xkeyboard-config"
109RRECOMMENDS_${PN} = "liberation-fonts"
110RRECOMMENDS_${PN}-dev += "wayland-protocols"
111
112USERADD_PACKAGES = "${PN}"
113GROUPADD_PARAM_${PN} = "--system weston-launch"
diff --git a/recipes-graphics/wayland/weston_2.0.0.bbappend b/recipes-graphics/wayland/weston_2.0.0.bbappend
deleted file mode 100644
index 7d0e589d..00000000
--- a/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ /dev/null
@@ -1,36 +0,0 @@
1SUMMARY_append = " (with i.MX support)"
2
3DEPENDS_append_imxgpu2d = " virtual/libg2d"
4
5# Use i.MX fork of weston for customizations.
6SRC_URI_remove_imxgpu2d = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
7SRC_URI_prepend_imxgpu2d = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=weston-imx-2.0 "
8SRCREV_imxgpu2d = "506dc2d69b7cf7b7e7d1ea94ce29c8203215a67e"
9S_imxgpu2d = "${WORKDIR}/git"
10
11# Define RECIPE_SYSROOT since it doesn't exist in morty
12# for this backported recipe
13RECIPE_SYSROOT = "${STAGING_DIR}/${MACHINE}"
14
15EXTRA_OECONF_IMX_COMMON = "WESTON_NATIVE_BACKEND=fbdev-backend.so"
16EXTRA_OECONF_IMX = ""
17EXTRA_OECONF_IMX_imxpxp = "${EXTRA_OECONF_IMX_COMMON}"
18EXTRA_OECONF_IMX_imxgpu2d = "${EXTRA_OECONF_IMX_COMMON}"
19EXTRA_OECONF_append = " ${EXTRA_OECONF_IMX}"
20
21# Disable OpenGL for parts with GPU support for 2D but not 3D
22IMX_REQUIRED_DISTRO_FEATURES_REMOVE = ""
23IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu2d = "opengl"
24IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = ""
25REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
26IMX_EXTRA_OECONF_OPENGL = ""
27IMX_EXTRA_OECONF_OPENGL_imxgpu2d = " --disable-opengl"
28IMX_EXTRA_OECONF_OPENGL_imxgpu3d = ""
29EXTRA_OECONF_append = "${IMX_EXTRA_OECONF_OPENGL}"
30
31PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2"
32
33# Append EGL_CFLAGS to CFLAGS for imxgpu2d
34CFLAGS_append_imxgpu2d = "-DLINUX -DEGL_API_FB -DWL_EGL_PLATFORM"
35
36RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)}"