summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xwayland
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-17 10:01:30 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-19 14:06:35 -0700
commitfa4112e43fc4edc4a8521eddd459606328be647e (patch)
tree5fa13cf5b94cae0ecd522fb561017d43468f4ac8 /recipes-graphics/xwayland
parent61718793a4c04c768ecc829372b9d4de3c6c463b (diff)
downloadmeta-freescale-fa4112e43fc4edc4a8521eddd459606328be647e.tar.gz
cairo,xwayland: Fix compiling with musl with vivante gpu driver libs
This ensures that the symbols from the prebuilt libs are not flagged during build, we are betting on gcompat to provide the missing glibc API stubs at runtime. Depend on gcompat on musl needed for imxgpu machines its needed since graphics driver is precompiled for glibc. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/xwayland')
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index 69063121..f2141f4f 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -10,3 +10,10 @@ OPENGL_PKGCONFIGS_REMOVE_IMXGPU = ""
10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx" 10OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx6-nxp-bsp = "glamor glx"
11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx" 11OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx7-nxp-bsp = "glamor glx"
12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx" 12OPENGL_PKGCONFIGS_REMOVE_IMXGPU:mx8-nxp-bsp = "glx"
13
14
15# links with imx-gpu libs which are pre-built for glibc
16# gcompat will address it during runtime
17LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
18
19RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"