summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xwayland
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-17 08:16:14 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-17 13:11:08 -0700
commit3da856d28cd38af366dc5940f9c4cd31986ec6c1 (patch)
treeaaf23b29830ad74e4862b1d536ab5d41f5056343 /recipes-graphics/xwayland
parent011aa5617d287aa83fff549494a63c4baad0c171 (diff)
downloadmeta-freescale-3da856d28cd38af366dc5940f9c4cd31986ec6c1.tar.gz
xwayland: Make local copy of 23.1.1 recipe
The langdale branch version of xwayland is incompatible with mickledore and master. To allow meta-freescale master to be compatible with langdale, mickledore, and master, make a local copy of the master version of xwayland and use it. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/xwayland')
-rw-r--r--recipes-graphics/xwayland/xwayland_23.1.1.imx.bb53
-rw-r--r--recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend (renamed from recipes-graphics/xwayland/xwayland_%.bbappend)0
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-graphics/xwayland/xwayland_23.1.1.imx.bb b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bb
new file mode 100644
index 00000000..a9705a23
--- /dev/null
+++ b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bb
@@ -0,0 +1,53 @@
1# This recipe copy helps keep meta-freescale master branch compatible
2# with Yocto langdale.
3# (From OE-Core rev: 35fdbd0ea81650a0421d50fb53989d96c5956331)
4
5SUMMARY = "XWayland is an X Server that runs under Wayland."
6DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
7and thus is capable of displaying native X11 client applications in a \
8Wayland compositor environment. The goal of XWayland is to facilitate \
9the transition from X Window System to Wayland environments, providing \
10a way to run unported applications in the meantime."
11HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
12
13DEFAULT_PREFERENCE = "-1"
14
15LICENSE = "MIT"
16LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
17
18SRC_URI = "https://www.x.org/archive/individual/xserver/${BP_ORIGINAL}.tar.xz"
19BP_ORIGINAL = "${BPN}-23.1.1"
20SRC_URI[sha256sum] = "fb9461f5cb9fea5e07e91882311b0c88b43e8843b017ebac05eb5af69aa34c15"
21S = "${WORKDIR}/${BP_ORIGINAL}"
22
23UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
24
25inherit meson features_check pkgconfig
26REQUIRED_DISTRO_FEATURES = "x11 opengl"
27
28DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt"
29
30OPENGL_PKGCONFIGS = "glx glamor dri3"
31PACKAGECONFIG ??= "${XORG_CRYPTO} \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
33"
34PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false,libxshmfence"
35PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
36PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
37PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
38PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
39
40# Xorg requires a SHA1 implementation, pick one
41XORG_CRYPTO ??= "openssl"
42PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
43PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
44PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
45
46do_install:append() {
47 # remove files not needed and clashing with xserver-xorg
48 rm -rf ${D}/${libdir}/xorg/
49}
50
51FILES:${PN} += "${libdir}/xorg/protocol.txt"
52
53RDEPENDS:${PN} += "xkbcomp"
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend
index 8515a538..8515a538 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_23.1.1.imx.bbappend