summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xwayland
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-04-10 10:01:43 -0700
committerKhem Raj <raj.khem@gmail.com>2023-04-25 09:15:02 -0700
commit315d018f17478b93a0151611edc7a8ccb0eac73f (patch)
tree890aba03e82ea4d10fa700a20bd756673df3304b /recipes-graphics/xwayland
parentb211cd09da29c82802a823f42ae0f5005616d2ef (diff)
downloadmeta-freescale-315d018f17478b93a0151611edc7a8ccb0eac73f.tar.gz
xwayland: Drop upstreamed patch to make use of GL_EXT_texture_format_BGRA8888
OE-core is soon upgrading to xwayland 23.x and this patch is already part of this release [1] Be aware that this would be post mickledore release, so this patch is not backportable to mickledore, its only for upcoming master and beyond. [1] https://gitlab.freedesktop.org/xorg/xserver/-/commit/24cd5f34f8edcc6621ed9c0f2b1a3df08de7488d Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/xwayland')
-rw-r--r--recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch39
-rw-r--r--recipes-graphics/xwayland/xwayland_%.bbappend1
2 files changed, 0 insertions, 40 deletions
diff --git a/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch b/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch
deleted file mode 100644
index 1c6cf2ec..00000000
--- a/recipes-graphics/xwayland/xwayland/0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 4508e54dae9d2884b2d6ccca13450b25d509cc9a Mon Sep 17 00:00:00 2001
2From: Xianzhong <xianzhong.li@nxp.com>
3Date: Thu, 5 Aug 2021 16:57:43 +0800
4Subject: [PATCH 3/3] glamor: Fix fbo pixmap format with GL_BGRA_EXT
5
6Red and Blue channels are swizzled in GLES path,
7Fix color inverse problem with ximagesink command:
8gst-launch-1.0 videotestsrc pattern=6 num-buffers=1 ! video/x-raw,format=BGRx ! videoconvert ! ximagesink display=:0 -v
9
10This fix requires GL_EXT_texture_format_BGRA8888 extension, not applicable for upstream.
11
12Upstream-Status: Inappropriate [embedded specific]
13Signed-off-by: Xianzhong <xianzhong.li@nxp.com>
14---
15 glamor/glamor.c | 7 +++++++
16 1 file changed, 7 insertions(+)
17
18Index: xwayland-21.1.4/glamor/glamor.c
19===================================================================
20--- xwayland-21.1.4.orig/glamor/glamor.c
21+++ xwayland-21.1.4/glamor/glamor.c
22@@ -586,10 +586,17 @@ glamor_setup_formats(ScreenPtr screen)
23
24 if (glamor_priv->is_gles) {
25 assert(X_BYTE_ORDER == X_LITTLE_ENDIAN);
26+#if GL_EXT_texture_format_BGRA8888
27+ glamor_add_format(screen, 24, PICT_x8r8g8b8,
28+ GL_BGRA_EXT, GL_BGRA_EXT, GL_UNSIGNED_BYTE, TRUE);
29+ glamor_add_format(screen, 32, PICT_a8r8g8b8,
30+ GL_BGRA_EXT, GL_BGRA_EXT, GL_UNSIGNED_BYTE, TRUE);
31+#else
32 glamor_add_format(screen, 24, PICT_x8b8g8r8,
33 GL_RGBA8, GL_RGBA, GL_UNSIGNED_BYTE, TRUE);
34 glamor_add_format(screen, 32, PICT_a8b8g8r8,
35 GL_RGBA8, GL_RGBA, GL_UNSIGNED_BYTE, TRUE);
36+#endif
37 } else {
38 glamor_add_format(screen, 24, PICT_x8r8g8b8,
39 GL_RGBA, GL_BGRA, GL_UNSIGNED_INT_8_8_8_8_REV, TRUE);
diff --git a/recipes-graphics/xwayland/xwayland_%.bbappend b/recipes-graphics/xwayland/xwayland_%.bbappend
index f2141f4f..8515a538 100644
--- a/recipes-graphics/xwayland/xwayland_%.bbappend
+++ b/recipes-graphics/xwayland/xwayland_%.bbappend
@@ -2,7 +2,6 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI:append:imxgpu = " \ 3SRC_URI:append:imxgpu = " \
4 file://0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch \ 4 file://0001-Prefer-to-create-GLES2-context-for-glamor-EGL.patch \
5 file://0002-glamor-Fix-fbo-pixmap-format-with-GL_BGRA_EXT.patch \
6" 5"
7 6
8OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}" 7OPENGL_PKGCONFIGS:remove:imxgpu = "${OPENGL_PKGCONFIGS_REMOVE_IMXGPU}"