summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-04-07 23:55:04 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-20 12:10:12 -0300
commitf5d3b67e3fb463d87588f8c9452f055e5d6f5a51 (patch)
treefb69608702d12852f70cdce84b6245661245f6ac /recipes-graphics/xorg-xserver
parent73e068409ffe01d6c52f329f3673cc601773f774 (diff)
downloadmeta-freescale-f5d3b67e3fb463d87588f8c9452f055e5d6f5a51.tar.gz
xserver-xorg: enable atomic/dri3
Inspired by [1-2] [1] https://gitlab.freedesktop.org/mesa/mesa/-/issues/4584 [2] https://gitlab.freedesktop.org/mesa/mesa/-/issues/3721 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Vinicius Aquino <voa.aquino@gmail.com>
Diffstat (limited to 'recipes-graphics/xorg-xserver')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf2
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch34
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend6
3 files changed, 42 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
index c58ae207..0c52ad3b 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/use-mainline-bsp/xorg.conf
@@ -3,9 +3,11 @@ Section "Device"
3 Driver "modesetting" 3 Driver "modesetting"
4 Option "kmsdev" "/dev/dri/card0" 4 Option "kmsdev" "/dev/dri/card0"
5 Option "AccelMethod" "glamor" 5 Option "AccelMethod" "glamor"
6 Option "Atomic" "On"
6EndSection 7EndSection
7 8
8Section "ServerFlags" 9Section "ServerFlags"
9 Option "AutoAddGPU" "false" 10 Option "AutoAddGPU" "false"
11 Option "DRI" "3"
10EndSection 12EndSection
11 13
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch b/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch
new file mode 100644
index 00000000..caf2fcd6
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg/0001-Allow-to-enable-atomic-in-modesetting-DDX.patch
@@ -0,0 +1,34 @@
1From 9c8b815520bf52caf780dc4defea0fe2fe8e33a3 Mon Sep 17 00:00:00 2001
2From: Daniel Abrecht <public@danielabrecht.ch>
3Date: Wed, 21 Oct 2020 21:13:30 +0200
4Subject: [PATCH] Allow to enable atomic in modesetting DDX
5
6The linux kernel blacklisted atomic for the modesetting DDX to deal with
7problems with old Xorg versions which didn't have it disabled by default.
8Ever since, it wasn't possible to enable atomic in modesetting at all
9anymore.
10
11This change doesn't enable atomic by default, but it allows a user to
12enabled it again.
13
14Signed-off-by: Daniel Abrecht <public@danielabrecht.ch>
15---
16 hw/xfree86/drivers/modesetting/driver.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/hw/xfree86/drivers/modesetting/driver.c b/hw/xfree86/drivers/modesetting/driver.c
20index 6549ef8e1..bd8576f81 100644
21--- a/hw/xfree86/drivers/modesetting/driver.c
22+++ b/hw/xfree86/drivers/modesetting/driver.c
23@@ -1216,7 +1216,7 @@ PreInit(ScrnInfoPtr pScrn, int flags)
24 }
25
26 if (xf86ReturnOptValBool(ms->drmmode.Options, OPTION_ATOMIC, FALSE)) {
27- ret = drmSetClientCap(ms->fd, DRM_CLIENT_CAP_ATOMIC, 1);
28+ ret = drmSetClientCap(ms->fd, DRM_CLIENT_CAP_ATOMIC, 2);
29 ms->atomic_modeset = (ret == 0);
30 } else {
31 ms->atomic_modeset = FALSE;
32--
33GitLab
34
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index a828e518..68c6d2d2 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -11,4 +11,10 @@ IMX_OPENGL_PKGCONFIGS_REMOVE = ""
11IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor" 11IMX_OPENGL_PKGCONFIGS_REMOVE_imxgpu = "glamor"
12OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 12OPENGL_PKGCONFIGS_remove_mx6 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
13OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}" 13OPENGL_PKGCONFIGS_remove_mx7 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
14OPENGL_PKGCONFIGS_remove_mx8 = "${IMX_OPENGL_PKGCONFIGS_REMOVE}"
14OPENGL_PKGCONFIGS_remove_imxdrm = "dri glx" 15OPENGL_PKGCONFIGS_remove_imxdrm = "dri glx"
16
17FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
18SRC_URI_append_imxgpu2d = " file://0003-Remove-check-for-useSIGIO-option.patch"
19SRC_URI_append_use-mainline-bsp = " file://0001-Allow-to-enable-atomic-in-modesetting-DDX.patch"
20