summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-18 05:27:09 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-18 05:27:09 -0700
commitfc6497ef28ba3aed379e63e8960e79cfee6d769b (patch)
treee55889ef727bb55d4c283a768fbe34cd2bf5c8b1 /recipes-graphics/wayland
parent47f0410be104d69c779f9e697b86eac9eb366a12 (diff)
downloadmeta-freescale-fc6497ef28ba3aed379e63e8960e79cfee6d769b.tar.gz
weston-init: Adjust use-g2d for weston 11
For the weston 11 fork, the use-g2d option type is changed from an integer to a boolean. Handle both cases. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index fa088b6f..3a91fbe6 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -37,6 +37,10 @@ PACKAGECONFIG_USE_G2D:mx8qm-nxp-bsp ?= ""
37PACKAGECONFIG_USE_G2D:mx8qxp-nxp-bsp ?= "" 37PACKAGECONFIG_USE_G2D:mx8qxp-nxp-bsp ?= ""
38PACKAGECONFIG_USE_G2D:mx8dx-nxp-bsp ?= "" 38PACKAGECONFIG_USE_G2D:mx8dx-nxp-bsp ?= ""
39 39
40USE_G2D_VALUE = "true"
41USE_G2D_VALUE:mx6-nxp-bsp = "1"
42USE_G2D_VALUE:mx7-nxp-bsp = "1"
43
40PACKAGECONFIG[gbm-format] = ",," 44PACKAGECONFIG[gbm-format] = ",,"
41PACKAGECONFIG[rdp] = ",," 45PACKAGECONFIG[rdp] = ",,"
42PACKAGECONFIG[repaint-window] = ",," 46PACKAGECONFIG[repaint-window] = ",,"
@@ -66,9 +70,9 @@ do_install:append() {
66 fi 70 fi
67 71
68 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then 72 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then
69 sed -i -e "/^\[core\]/a use-g2d=1" ${D}${sysconfdir}/xdg/weston/weston.ini 73 sed -i -e "/^\[core\]/a use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
70 else 74 else
71 sed -i -e "/^\[core\]/a #use-g2d=1" ${D}${sysconfdir}/xdg/weston/weston.ini 75 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
72 fi 76 fi
73 77
74 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini 78 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini