summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-07-11 22:05:47 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-07-12 09:21:51 +0200
commitecb8d8986d5a46b7cacde50a1f16e9b03840f8e0 (patch)
treedc249c1ffbb9e1ccb50ede56189663e947f91e3a /recipes-graphics/wayland
parent02870132a53fed8620302984541a623cfa5d3149 (diff)
downloadmeta-freescale-ecb8d8986d5a46b7cacde50a1f16e9b03840f8e0.tar.gz
weston: 9.0.0.imx: fix build with latest master
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch40
-rw-r--r--recipes-graphics/wayland/weston_9.0.0.imx.bb4
2 files changed, 43 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch b/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
new file mode 100644
index 00000000..dde00546
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
@@ -0,0 +1,40 @@
1From be066d9841a9cd5e9cc5ef3c457bd1e33b2a5fae Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Mon, 11 Jul 2022 19:38:19 +0000
4Subject: [PATCH] Revert "protocol: no found wayland-scanner with Yocto
5 toolchain"
6
7This reverts commit 7859a762617682bd804e210ad3bda6bdcd3ea24a.
8
9With openembedded commit e525db4eb9 ("wayland: update 1.20.0 -> 1.21.0")
10package config seems no longer to provide the path to the native
11weston scanner.
12
13Thus the build fails with:
14
15| Run-time dependency wayland-scanner found: YES 1.21.0
16| Program /usr/bin/wayland-scanner found: NO
17|
18| ../git/protocol/meson.build:2:0: ERROR: Program '/usr/bin/wayland-scanner' not found or not executable
19
20Dropping weston 9.0.0-imx commit 7859a762 (protocol: no found
21wayland-scanner with Yocto toolchain") fixes the issue.
22
23Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
24---
25 protocol/meson.build | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/protocol/meson.build b/protocol/meson.build
29index dc90ec2a..8290ad44 100644
30--- a/protocol/meson.build
31+++ b/protocol/meson.build
32@@ -1,4 +1,4 @@
33-dep_scanner = dependency('wayland-scanner', native: false)
34+dep_scanner = dependency('wayland-scanner', native: true)
35 prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
36
37 dep_wp = dependency('wayland-protocols', version: '>= 1.18')
38--
392.20.1
40
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bb b/recipes-graphics/wayland/weston_9.0.0.imx.bb
index 228cf4fa..63143787 100644
--- a/recipes-graphics/wayland/weston_9.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_9.0.0.imx.bb
@@ -162,7 +162,9 @@ SRCBRANCH = "weston-imx-9.0"
162SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ 162SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
163 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ 163 file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \
164" 164"
165SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " 165SRC_URI:prepend = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \
166 file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch \
167"
166SRCREV = "7859a762617682bd804e210ad3bda6bdcd3ea24a" 168SRCREV = "7859a762617682bd804e210ad3bda6bdcd3ea24a"
167S = "${WORKDIR}/git" 169S = "${WORKDIR}/git"
168 170