summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-17 09:51:10 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-17 13:24:46 -0700
commite7ff896868a592dcba3ce2b549116c1e4e7fec11 (patch)
tree3417b0f670394d1466ef6213f4b8dbf3d3c6810c /recipes-graphics/wayland
parente01382f94a11732d230cc4e2329c01e3219d3932 (diff)
downloadmeta-freescale-e7ff896868a592dcba3ce2b549116c1e4e7fec11.tar.gz
weston: Upgrade 10.0.1.imx -> 10.0.3.imx
- Update OE-Core copy to 4b42fd8 - Drop dont-use-plane-add-prop.patch - Move fbdev dependency on libdrm to i.MX overrides section - Make removal of wayland and x11 from PACKAGECONFIG overridable Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston/dont-use-plane-add-prop.patch23
-rw-r--r--recipes-graphics/wayland/weston_10.0.3.imx.bb (renamed from recipes-graphics/wayland/weston_10.0.1.imx.bb)28
2 files changed, 12 insertions, 39 deletions
diff --git a/recipes-graphics/wayland/weston/dont-use-plane-add-prop.patch b/recipes-graphics/wayland/weston/dont-use-plane-add-prop.patch
deleted file mode 100644
index a4444e5d..00000000
--- a/recipes-graphics/wayland/weston/dont-use-plane-add-prop.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Fix atomic modesetting with musl
2
3atomic modesetting seems to fail with drm weston backend and this patch fixes
4it, below errors are seen before weston exits
5
6atomic: couldn't commit new state: Invalid argument
7
8Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/weston/-/issues/158]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11--- a/libweston/backend-drm/kms.c
12+++ b/libweston/backend-drm/kms.c
13@@ -1168,8 +1168,8 @@ drm_pending_state_apply_atomic(struct dr
14 wl_list_for_each(plane, &b->plane_list, link) {
15 drm_debug(b, "\t\t[atomic] starting with plane %lu disabled\n",
16 (unsigned long) plane->plane_id);
17- plane_add_prop(req, plane, WDRM_PLANE_CRTC_ID, 0);
18- plane_add_prop(req, plane, WDRM_PLANE_FB_ID, 0);
19+ //plane_add_prop(req, plane, WDRM_PLANE_CRTC_ID, 0);
20+ //plane_add_prop(req, plane, WDRM_PLANE_FB_ID, 0);
21 }
22
23 flags |= DRM_MODE_ATOMIC_ALLOW_MODESET;
diff --git a/recipes-graphics/wayland/weston_10.0.1.imx.bb b/recipes-graphics/wayland/weston_10.0.3.imx.bb
index 470a7b0b..f3e913fc 100644
--- a/recipes-graphics/wayland/weston_10.0.1.imx.bb
+++ b/recipes-graphics/wayland/weston_10.0.3.imx.bb
@@ -3,28 +3,27 @@
3# recipe. The second section customizes the recipe for i.MX. 3# recipe. The second section customizes the recipe for i.MX.
4 4
5########### OE-core copy ################## 5########### OE-core copy ##################
6# Upstream hash: 400aae43d08f0b9f787ac0d21cb3c97058d76748 6# Upstream hash: 4b42fd87da290ddea098605aea3a5cce1fb432a7
7 7
8SUMMARY = "Weston, a Wayland compositor" 8SUMMARY = "Weston, a Wayland compositor"
9DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" 9DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
10HOMEPAGE = "http://wayland.freedesktop.org" 10HOMEPAGE = "http://wayland.freedesktop.org"
11LICENSE = "MIT" 11LICENSE = "MIT"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ 12LIC_FILES_CHKSUM = "file://LICENSE;md5=d79ee9e66bb0f95d3386a7acae780b70 \
13 file://libweston/compositor.c;endline=27;md5=eb6d5297798cabe2ddc65e2af519bcf0 \ 13 file://libweston/compositor.c;endline=27;md5=eb6d5297798cabe2ddc65e2af519bcf0 \
14 " 14 "
15 15
16SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ 16SRC_URI = "https://gitlab.freedesktop.org/wayland/weston/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz \
17 file://weston.png \ 17 file://weston.png \
18 file://weston.desktop \ 18 file://weston.desktop \
19 file://xwayland.weston-start \ 19 file://xwayland.weston-start \
20 file://systemd-notify.weston-start \ 20 file://systemd-notify.weston-start \
21 " 21 "
22 22
23SRC_URI:append:libc-musl = " file://dont-use-plane-add-prop.patch " 23SRC_URI[sha256sum] = "89646ca0d9f8d413c2767e5c3828eaa3fa149c2a105b3729a6894fa7cf1549e7"
24
25SRC_URI[sha256sum] = "5c23964112b90238bed39e5dd1e41cd71a79398813cdc3bbb15a9fdc94e547ae"
26 24
27UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" 25UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
26UPSTREAM_CHECK_REGEX = "weston-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
28 27
29inherit meson pkgconfig useradd 28inherit meson pkgconfig useradd
30 29
@@ -34,7 +33,6 @@ require ${THISDIR}/required-distro-features.inc
34 33
35DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0" 34DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0"
36DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" 35DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
37DEPENDS:append:imxfbdev = " libdrm"
38 36
39LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}" 37LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}"
40 38
@@ -159,15 +157,12 @@ SUMMARY = "Weston, a Wayland compositor, i.MX fork"
159 157
160DEFAULT_PREFERENCE = "-1" 158DEFAULT_PREFERENCE = "-1"
161 159
162SRC_URI:remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz" 160SRC_URI:remove = "https://gitlab.freedesktop.org/wayland/weston/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz"
163SRC_URI:prepend = "git://github.com/nxp-imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} " 161SRC_URI:prepend = "git://github.com/nxp-imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} "
164SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch \ 162SRC_URI += "file://0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch \
165 file://0001-g2d-renderer.c-Include-sys-stat.h.patch \ 163 file://0001-g2d-renderer.c-Include-sys-stat.h.patch"
166 file://0001-tests-Add-dependency-on-screenshooter-client-protoco.patch \ 164SRCBRANCH = "weston-imx-10.0.3"
167 " 165SRCREV = "c41675dc616886828219eba9b9ce22ec17533090"
168SRCBRANCH = "weston-imx-10.0.1"
169SRCREV = "3f8f336b5d2cf7ea7aa4e047d669d093fc46dfe6"
170
171S = "${WORKDIR}/git" 166S = "${WORKDIR}/git"
172 167
173# Disable OpenGL for parts with GPU support for 2D but not 3D 168# Disable OpenGL for parts with GPU support for 2D but not 3D
@@ -178,7 +173,8 @@ PACKAGECONFIG_OPENGL = "opengl"
178PACKAGECONFIG_OPENGL:imxgpu2d = "" 173PACKAGECONFIG_OPENGL:imxgpu2d = ""
179PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" 174PACKAGECONFIG_OPENGL:imxgpu3d = "opengl"
180 175
181PACKAGECONFIG:remove = "wayland x11" 176PACKAGECONFIG_IMX_REMOVALS ?= "wayland x11"
177PACKAGECONFIG:remove = "${PACKAGECONFIG_IMX_REMOVALS}"
182PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" 178PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}"
183 179
184PACKAGECONFIG:remove:imxfbdev = "kms" 180PACKAGECONFIG:remove:imxfbdev = "kms"
@@ -197,7 +193,7 @@ PACKAGECONFIG[imxg2d] = "-Drenderer-g2d=true,-Drenderer-g2d=false,virtual/libg2d
197# Weston with OpenGL support 193# Weston with OpenGL support
198PACKAGECONFIG[opengl] = "-Dopengl=true,-Dopengl=false" 194PACKAGECONFIG[opengl] = "-Dopengl=true,-Dopengl=false"
199 195
200PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev" 196PACKAGECONFIG[fbdev] = "-Dbackend-fbdev=true,-Dbackend-fbdev=false,udev mtdev libdrm"
201EXTRA_OEMESON:append:imxfbdev = " -Dbackend-default=fbdev" 197EXTRA_OEMESON:append:imxfbdev = " -Dbackend-default=fbdev"
202 198
203EXTRA_OEMESON += "-Ddeprecated-wl-shell=true" 199EXTRA_OEMESON += "-Ddeprecated-wl-shell=true"