summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-31 17:39:35 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-03-31 19:37:58 -0500
commitd93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch)
tree5111741914b7fcb87aac225fa886c757e782456b /recipes-graphics/wayland
parent65398605b9f412ac851c945f4cbe36a81b899a8f (diff)
downloadmeta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and the rework of the SOC overrides didn't handle it properly, leading to a build break: ``` Log data follows: | DEBUG: Executing shell function do_compile | NOTE: 8QX boot binary build | cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory | WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$ tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin' | WARNING: Backtrace (BB generated script): | #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179 | #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151 | #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189 ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1' ``` Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting existing mx8qxp overrides appropriately. Fixes: #1027 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 7aceb6b1..4ba6cba7 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -27,9 +27,10 @@ INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq-nxp-bsp = " \
27# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it 27# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it
28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest 28# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest
29# rendering code. 29# rendering code.
30INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1" 30INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1"
31INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp = "" 31INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp = ""
32INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp = "" 32INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp = ""
33INI_UNCOMMENT_USE_G2D:mx8dx-nxp-bsp = ""
33INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \ 34INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \
34 ${INI_UNCOMMENT_USE_G2D} \ 35 ${INI_UNCOMMENT_USE_G2D} \
35" 36"