summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2023-06-06 13:18:59 +0200
committerMing Liu <liu.ming50@gmail.com>2023-06-07 14:50:57 +0200
commit7532cfdc224e50a2e9e1e55f9bc73991256ac743 (patch)
tree0de479e75081547b72a5a001fc92b5b5c7090823 /recipes-graphics/wayland
parent8995442f5432852a0313d83eb5fbc0fbd9e1c595 (diff)
downloadmeta-freescale-7532cfdc224e50a2e9e1e55f9bc73991256ac743.tar.gz
weston-init: disable xwayland for mainline BSPs
A regression was introduced by commit 47f0410be1: [ weston-init: Rework weston.ini configuration ] xwayland had been dropped from weston.ini for mainline BSPs before that commit, since it's not supported by mainline BSPs: [ weston-init: comment in xwayland=true for mainline BSPs The main recipe now sets xwayland=true in weston.ini, but xwayland does not really work for mainline BSPs, the following error was observed on both imx6/imx7 machines, as follows: ``` | # gst-play-1.0 testvideo_h264_360p.mp4 | Press 'k' to see a list of keyboard shortcuts. | Now playing testvideo_h264_360p.mp4 | X connection to :0.0 broken (explicit kill or server shutdown). ``` after removing "xwayland=true" from weston.ini, it works again. This patch mainly aims to resolve this problem by introducing a variable INI_COMMENT_ASSIGNMENTS that the end users could set to comment a line in weston.ini. ] but after commit 47f0410be1, "xwayland=true" is added back again to weston.ini. Introduce a xwayland PACKAGECONFIG to control that, drop it from weston.ini for mainline BSPs. Signed-off-by: Ming Liu <liu.ming50@gmail.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 69a807a3..595633b0 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -10,12 +10,16 @@ SRC_URI:append:mx6sl-nxp-bsp = " file://weston.config"
10 10
11PACKAGECONFIG ??= " \ 11PACKAGECONFIG ??= " \
12 no-idle-timeout \ 12 no-idle-timeout \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xwayland', '', d)} \
13 ${PACKAGECONFIG_GBM_FORMAT} \ 14 ${PACKAGECONFIG_GBM_FORMAT} \
14 ${PACKAGECONFIG_REPAINT_WINDOW} \ 15 ${PACKAGECONFIG_REPAINT_WINDOW} \
15 ${PACKAGECONFIG_SIZE} \ 16 ${PACKAGECONFIG_SIZE} \
16 ${PACKAGECONFIG_USE_G2D} \ 17 ${PACKAGECONFIG_USE_G2D} \
17" 18"
18 19
20# Mainline BSPs dont support xwayland
21PACKAGECONFIG:remove:use-mainline-bsp = "xwayland"
22
19PACKAGECONFIG_GBM_FORMAT ?= "" 23PACKAGECONFIG_GBM_FORMAT ?= ""
20PACKAGECONFIG_GBM_FORMAT:mx8mq-nxp-bsp ?= "gbm-format" 24PACKAGECONFIG_GBM_FORMAT:mx8mq-nxp-bsp ?= "gbm-format"
21 25
@@ -46,6 +50,7 @@ PACKAGECONFIG[rdp] = ",,"
46PACKAGECONFIG[repaint-window] = ",," 50PACKAGECONFIG[repaint-window] = ",,"
47PACKAGECONFIG[size] = ",," 51PACKAGECONFIG[size] = ",,"
48PACKAGECONFIG[use-g2d] = ",," 52PACKAGECONFIG[use-g2d] = ",,"
53PACKAGECONFIG[xwayland] = ",,"
49 54
50do_install:append() { 55do_install:append() {
51 if [ -f "${WORKDIR}/weston.config" ]; then 56 if [ -f "${WORKDIR}/weston.config" ]; then
@@ -75,5 +80,9 @@ do_install:append() {
75 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini 80 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
76 fi 81 fi
77 82
83 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "no" ]; then
84 sed -i -e "s/^xwayland=true/#xwayland=true/g" ${D}${sysconfdir}/xdg/weston/weston.ini
85 fi
86
78 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini 87 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
79} 88}