summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_5.0.0.imx.bb
diff options
context:
space:
mode:
authorMihai Lindner <mihai.lindner@nxp.com>2019-12-16 13:53:19 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-16 14:06:39 -0300
commita4fdb4074644bda09b46490163886065b4c00aab (patch)
tree2a37b5ce4dc1b8f460c9c9a4de50326951349460 /recipes-graphics/wayland/weston_5.0.0.imx.bb
parentca58ffe4a593b75b00fd53145690f84eb1e663ee (diff)
downloadmeta-freescale-a4fdb4074644bda09b46490163886065b4c00aab.tar.gz
weston: Upgrade to 6.0.1.imx
Signed-off-by: Mihai Lindner <mihai.lindner@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland/weston_5.0.0.imx.bb')
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb140
1 files changed, 0 insertions, 140 deletions
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
deleted file mode 100644
index a7778b41..00000000
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ /dev/null
@@ -1,140 +0,0 @@
1SUMMARY = "Weston, a Wayland compositor, i.MX fork"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=26;md5=f47553ae598090444273db00adfb5b66"
7
8DEFAULT_PREFERENCE = "-1"
9
10SRCBRANCH = "weston-imx-5.0"
11SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \
12 file://weston.png \
13 file://weston.desktop \
14 file://0001-make-error-portable.patch \
15 file://xwayland.weston-start \
16 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
17 file://0003-weston-touch-calibrator-Advertise-the-touchscreen-ca.patch \
18"
19SRCREV = "fb563901657b296c7c7c86d26602a622429e334f"
20S = "${WORKDIR}/git"
21
22UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
23
24inherit autotools pkgconfig useradd features_check
25
26# Disable OpenGL for parts with GPU support for 2D but not 3D
27REQUIRED_DISTRO_FEATURES = "opengl"
28REQUIRED_DISTRO_FEATURES_imxgpu2d = ""
29REQUIRED_DISTRO_FEATURES_imxgpu3d = "opengl"
30PACKAGECONFIG_OPENGL = "opengl"
31PACKAGECONFIG_OPENGL_imxgpu2d = ""
32PACKAGECONFIG_OPENGL_imxgpu3d = "opengl"
33
34DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
35DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
36
37WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
38
39EXTRA_OECONF = "--enable-setuid-install \
40 --disable-rdp-compositor \
41 "
42EXTRA_OECONF_append_qemux86 = " \
43 WESTON_NATIVE_BACKEND=fbdev-backend.so \
44 "
45EXTRA_OECONF_append_qemux86-64 = " \
46 WESTON_NATIVE_BACKEND=fbdev-backend.so \
47 "
48EXTRA_OECONF_append_imxfbdev = " \
49 WESTON_NATIVE_BACKEND=fbdev-backend.so \
50 "
51PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
53 ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL} pam systemd x11', d)} \
54 clients launch"
55PACKAGECONFIG_remove_imxfbdev = "kms"
56PACKAGECONFIG_append_imxgpu = " imxgpu"
57PACKAGECONFIG_append_imxgpu2d = " imxg2d"
58PACKAGECONFIG_append_imxgpu3d = " cairo-glesv2"
59#
60# Compositor choices
61#
62# Weston on KMS
63PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev"
64# Weston on Wayland (nested Weston)
65PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
66# Weston on X11
67PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
68# Headless Weston
69PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor"
70# Weston on framebuffer
71PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
72# weston-launch
73PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm"
74# VA-API desktop recorder
75PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"
76# Weston with EGL support
77PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl"
78# Weston with cairo glesv2 support
79PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo"
80# Weston with lcms support
81PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
82# Weston with webp support
83PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
84# Weston with systemd-login support
85PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus"
86# Weston with Xwayland support (requires X11 and Wayland)
87PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland"
88# colord CMS support
89PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord"
90# Clients support
91PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients"
92# Weston with PAM support
93PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam"
94# Weston with i.MX GPU support
95PACKAGECONFIG[imxgpu] = "--enable-imxgpu,--disable-imxgpu"
96# Weston with i.MX G2D renderer
97PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d"
98# Weston with OpenGL support
99PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl"
100
101do_install_append() {
102 # Weston doesn't need the .la files to load modules, so wipe them
103 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
104
105 # If X11, ship a desktop file to launch it
106 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
107 install -d ${D}${datadir}/applications
108 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
109
110 install -d ${D}${datadir}/icons/hicolor/48x48/apps
111 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
112 fi
113
114 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
115 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
116 fi
117}
118
119PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
120 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples"
121
122FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir} ${sysconfdir}/xdg/weston"
123
124FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so"
125SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'."
126
127FILES_${PN}-examples = "${bindir}/*"
128
129FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so"
130RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland"
131
132RDEPENDS_${PN} += "xkeyboard-config"
133RRECOMMENDS_${PN} = "liberation-fonts"
134RRECOMMENDS_${PN}-dev += "wayland-protocols"
135
136USERADD_PACKAGES = "${PN}"
137GROUPADD_PARAM_${PN} = "--system weston-launch"
138
139PACKAGE_ARCH = "${MACHINE_SOCARCH}"
140COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)"