summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston_5.0.0.imx.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-11-17 09:25:11 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-18 10:16:54 -0300
commit66989b7d07f8a1cdd4050fe3e3b088b6ead80786 (patch)
tree1c3128a787b5fc796d687063fa8daea525685550 /recipes-graphics/wayland/weston_5.0.0.imx.bb
parent152747a8fdf15ce0ea8bbe944d05139875c8223d (diff)
downloadmeta-freescale-66989b7d07f8a1cdd4050fe3e3b088b6ead80786.tar.gz
weston-init: Move weston.ini install to weston-init
OE-core now installs weston.ini from weston-init, so align our recipe to do the same. The IVI dynamic layer now has a copy of the weston.ini file that is normally produced by the weston build. The AGL dynamic layer now uninstalls the weston.ini installed upstream. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland/weston_5.0.0.imx.bb')
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb12
1 files changed, 0 insertions, 12 deletions
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index e9f354f0..270aa2ad 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -16,10 +16,6 @@ SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=http
16 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ 16 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
17 file://0003-weston-touch-calibrator-Advertise-the-touchscreen-ca.patch \ 17 file://0003-weston-touch-calibrator-Advertise-the-touchscreen-ca.patch \
18" 18"
19# Use argb8888 as gbm-format for i.MX8MQ only
20SRC_URI_append_mx8mq = " file://0001-weston.ini-using-argb8888-as-gbm-default-on-mscale-8.patch \
21 file://0002-weston.ini-configure-desktop-shell-size-in-weston-co.patch \
22"
23SRCREV = "fb563901657b296c7c7c86d26602a622429e334f" 19SRCREV = "fb563901657b296c7c7c86d26602a622429e334f"
24S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
25 21
@@ -102,9 +98,6 @@ PACKAGECONFIG[imxg2d] = "--enable-imxg2d,--disable-imxg2d,virtual/libg2d"
102# Weston with OpenGL support 98# Weston with OpenGL support
103PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl" 99PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl"
104 100
105# Set to install a default weston.ini file
106WESTON_INI_INSTALL_FILE = "${B}/weston.ini"
107
108do_install_append() { 101do_install_append() {
109 # Weston doesn't need the .la files to load modules, so wipe them 102 # Weston doesn't need the .la files to load modules, so wipe them
110 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la 103 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
@@ -121,11 +114,6 @@ do_install_append() {
121 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then 114 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
122 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland 115 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
123 fi 116 fi
124
125 # install default weston.ini
126 if [ "${WESTON_INI_INSTALL_FILE}" != "" ]; then
127 install -D -m 0644 ${WESTON_INI_INSTALL_FILE} ${D}${sysconfdir}/xdg/weston/weston.ini
128 fi
129} 117}
130 118
131PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ 119PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \