summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston-10.0.5.imx
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-04-24 14:40:22 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-04-24 16:17:06 -0700
commit84bb2909ec03f4e8212e23836b8e8e0ec6933991 (patch)
tree7d1c1c4ef56a6ab53dd5fb2a518595db10af586d /recipes-graphics/wayland/weston-10.0.5.imx
parent771e4ececae9dc0b0a562c7321d94376849898e8 (diff)
downloadmeta-freescale-84bb2909ec03f4e8212e23836b8e8e0ec6933991.tar.gz
weston: Upgrade 10.0.4.imx -> 10.0.5.imx
Align with NXP BSP 6.6.3-1.0.0. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/wayland/weston-10.0.5.imx')
-rw-r--r--recipes-graphics/wayland/weston-10.0.5.imx/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch41
-rw-r--r--recipes-graphics/wayland/weston-10.0.5.imx/0001-g2d-renderer.c-Include-sys-stat.h.patch34
2 files changed, 75 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-10.0.5.imx/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch b/recipes-graphics/wayland/weston-10.0.5.imx/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
new file mode 100644
index 00000000..59f2a4b6
--- /dev/null
+++ b/recipes-graphics/wayland/weston-10.0.5.imx/0001-Revert-protocol-no-found-wayland-scanner-with-Yocto-.patch
@@ -0,0 +1,41 @@
1From 77eba6f6b04ff21b77c41500657495b4fd12a5f6 Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Mon, 11 Jul 2022 19:38:19 +0000
4Subject: [PATCH] Revert "protocol: no found wayland-scanner with Yocto
5 toolchain"
6
7This reverts commit 7859a762617682bd804e210ad3bda6bdcd3ea24a.
8
9With openembedded commit e525db4eb9 ("wayland: update 1.20.0 -> 1.21.0")
10package config seems no longer to provide the path to the native
11weston scanner.
12
13Thus the build fails with:
14
15| Run-time dependency wayland-scanner found: YES 1.21.0
16| Program /usr/bin/wayland-scanner found: NO
17|
18| ../git/protocol/meson.build:2:0: ERROR: Program '/usr/bin/wayland-scanner' not found or not executable
19
20Dropping weston 9.0.0-imx commit 7859a762 (protocol: no found
21wayland-scanner with Yocto toolchain") fixes the issue.
22
23Upstream-Status: Inappropriate [Cross-compile Specific]
24Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
25---
26 protocol/meson.build | 2 +-
27 1 file changed, 1 insertion(+), 1 deletion(-)
28
29diff --git a/protocol/meson.build b/protocol/meson.build
30index bdd322ac..e50b23bb 100644
31--- a/protocol/meson.build
32+++ b/protocol/meson.build
33@@ -1,4 +1,4 @@
34-dep_scanner = dependency('wayland-scanner', native: false)
35+dep_scanner = dependency('wayland-scanner', native: true)
36 prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
37
38 dep_wp = dependency('wayland-protocols', version: '>= 1.24')
39--
402.17.1
41
diff --git a/recipes-graphics/wayland/weston-10.0.5.imx/0001-g2d-renderer.c-Include-sys-stat.h.patch b/recipes-graphics/wayland/weston-10.0.5.imx/0001-g2d-renderer.c-Include-sys-stat.h.patch
new file mode 100644
index 00000000..b9cb31fb
--- /dev/null
+++ b/recipes-graphics/wayland/weston-10.0.5.imx/0001-g2d-renderer.c-Include-sys-stat.h.patch
@@ -0,0 +1,34 @@
1From 4afe9b2f9ef24ce0c9bf1cd41f94ca45afa4f445 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 12 Sep 2022 20:58:14 -0700
4Subject: [PATCH] g2d-renderer.c: Include sys/stat.h
5
6This is needed for getting stat() prototype, its flagged with clang-15
7as error.
8
9| ../git/libweston/renderer-g2d/g2d-renderer.c:2057:6: error: call to undeclared function 'stat'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
10| if (stat(gr->drm_device, &dev_stat) != 0) {
11| ^
12| 1 error generated.
13
14Upstream-Status: Pending
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 libweston/renderer-g2d/g2d-renderer.c | 1 +
18 1 file changed, 1 insertion(+)
19
20diff --git a/libweston/renderer-g2d/g2d-renderer.c b/libweston/renderer-g2d/g2d-renderer.c
21index f59fc4ee..36a458fc 100644
22--- a/libweston/renderer-g2d/g2d-renderer.c
23+++ b/libweston/renderer-g2d/g2d-renderer.c
24@@ -41,6 +41,7 @@
25 #include <drm_fourcc.h>
26 #include <poll.h>
27 #include <errno.h>
28+#include <sys/stat.h> /* stat() */
29
30 #include <libweston/libweston.h>
31 #include "g2d-renderer.h"
32--
332.37.3
34