summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/waffle
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-29 11:34:11 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-29 11:34:11 -0700
commite3c24d98feb10bc033bbff7534f5aced3e791cac (patch)
treea0c612e43d9456f3801dd3c3346f0a892b51269f /recipes-graphics/waffle
parent348d3a23be97e0d8827d7a4938c85cb6e62f79d5 (diff)
downloadmeta-freescale-e3c24d98feb10bc033bbff7534f5aced3e791cac.tar.gz
waffle: Forward port the patch to latest waffle
OE-core has new version Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/waffle')
-rw-r--r--recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch28
1 files changed, 13 insertions, 15 deletions
diff --git a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
index b5225693..5f587d84 100644
--- a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
+++ b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
@@ -14,19 +14,17 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14 meson.build | 6 ++++-- 14 meson.build | 6 ++++--
15 1 file changed, 4 insertions(+), 2 deletions(-) 15 1 file changed, 4 insertions(+), 2 deletions(-)
16 16
17diff --git a/meson.build b/meson.build
18index ca8b127..efb51f4 100644
19--- a/meson.build 17--- a/meson.build
20+++ b/meson.build 18+++ b/meson.build
21@@ -65,6 +65,7 @@ dep_gl = _dep_null 19@@ -63,6 +63,7 @@ dep_gl = _dep_null
22 dep_egl = _dep_null 20 dep_egl = _dep_null
23 dep_wayland_client = _dep_null 21 dep_wayland_client = _dep_null
24 dep_wayland_egl = _dep_null 22 dep_wayland_egl = _dep_null
25+dep_wayland_wayland_egl = _dep_null 23+dep_wayland_wayland_egl = _dep_null
24 dep_wayland_scanner = _dep_null
25 dep_wayland_proto = _dep_null
26 dep_x11_xcb = _dep_null 26 dep_x11_xcb = _dep_null
27 dep_gbm = _dep_null 27@@ -104,7 +105,8 @@ else
28 dep_udev = _dep_null
29@@ -90,7 +91,8 @@ else
30 dep_wayland_client = dependency( 28 dep_wayland_client = dependency(
31 'wayland-client', version : '>= 1.10', required : get_option('wayland'), 29 'wayland-client', version : '>= 1.10', required : get_option('wayland'),
32 ) 30 )
@@ -35,13 +33,13 @@ index ca8b127..efb51f4 100644
35+ dep_wayland_wayland_egl = dependency( 33+ dep_wayland_wayland_egl = dependency(
36 'wayland-egl', version : '>= 9.1', required : get_option('wayland'), 34 'wayland-egl', version : '>= 9.1', required : get_option('wayland'),
37 ) 35 )
38 dep_x11_xcb = dependency('x11-xcb', required : get_option('glx')) 36 dep_wayland_scanner = dependency(
39@@ -101,7 +103,7 @@ else 37@@ -120,7 +122,7 @@ else
40 dep_udev = dependency('libudev', required : get_option('gbm')) 38 wayland_xdg_shell_xml = join_paths(dep_wayland_proto.get_pkgconfig_variable('pkgdatadir'),
39 'stable/xdg-shell/xdg-shell.xml')
40 endif
41- build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found()
42+ build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found() and dep_wayland_wayland_egl.found()
41 43
42 build_x11_egl = dep_egl.found() 44 # We're interested only in the headers provided
43- build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() 45 # FINISHME: make x11_xcb and udev compile-only dependency
44+ build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_wayland_egl.found()
45 build_glx = dep_gl.found()
46 build_gbm = dep_gbm.found() and dep_udev.found()
47 build_surfaceless = dep_egl.found()