summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/waffle
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-29 12:41:45 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-29 12:42:20 -0700
commitadc9d50ca9bc802fce150e1917f24a2010d9fa4c (patch)
treeccef5be8de7471abd6323b7e2c87ea1b480e4051 /recipes-graphics/waffle
parent557cd06e3482392b33d8a199540c3dde8bb47924 (diff)
downloadmeta-freescale-adc9d50ca9bc802fce150e1917f24a2010d9fa4c.tar.gz
waffle: Forward port Separate-surfaceless-option-from-x11 patch as well
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/waffle')
-rw-r--r--recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch16
1 files changed, 6 insertions, 10 deletions
diff --git a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
index 9d5003e2..2a680cc6 100644
--- a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
+++ b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
@@ -14,8 +14,6 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14 meson.build | 5 ++++- 14 meson.build | 5 ++++-
15 1 file changed, 4 insertions(+), 1 deletion(-) 15 1 file changed, 4 insertions(+), 1 deletion(-)
16 16
17diff --git a/meson.build b/meson.build
18index efb51f4..0ee3ee5 100644
19--- a/meson.build 17--- a/meson.build
20+++ b/meson.build 18+++ b/meson.build
21@@ -72,6 +72,7 @@ dep_udev = _dep_null 19@@ -72,6 +72,7 @@ dep_udev = _dep_null
@@ -26,19 +24,17 @@ index efb51f4..0ee3ee5 100644
26 24
27 # Get dependencies 25 # Get dependencies
28 if build_wgl 26 if build_wgl
29@@ -101,12 +102,14 @@ else 27@@ -96,10 +97,11 @@ else
30 endif 28 dep_egl = dependency('egl', required : get_option('gbm'))
31 dep_gbm = dependency('gbm', required : get_option('gbm')) 29 dep_gbm = dependency('gbm', required : get_option('gbm'))
32 dep_udev = dependency('libudev', required : get_option('gbm')) 30 dep_udev = dependency('libudev', required : get_option('gbm'))
33+ dep_surfaceless_egl = dependency('egl', required : get_option('surfaceless_egl')) 31+ dep_surfaceless_egl = dependency('egl', required : get_option('surfaceless_egl'))
34+ dep_surfaceless_gbm = dependency('gbm', required : get_option('surfaceless_egl')) 32+ dep_surfaceless_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
33 build_gbm = dep_egl.found() and dep_gbm.found() and dep_udev.found()
35 34
36 build_x11_egl = dep_egl.found() 35- dep_egl = dependency('egl', required : get_option('surfaceless_egl'))
37 build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_wayland_egl.found()
38 build_glx = dep_gl.found()
39 build_gbm = dep_gbm.found() and dep_udev.found()
40- build_surfaceless = dep_egl.found() 36- build_surfaceless = dep_egl.found()
41+ build_surfaceless = dep_surfaceless_egl.found() and dep_surfaceless_gbm.found() 37+ build_surfaceless = dep_surfaceless_egl.found() and dep_surfaceless_gbm.found()
42 endif
43 38
44 dep_bash = dependency('bash-completion', required : false) 39 dep_egl = dependency('egl', required : get_option('wayland'))
40 dep_wayland_client = dependency(