summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/waffle
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-06-07 20:54:21 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-06-08 08:38:17 -0300
commit81262efe6e9eb8ac0ed345abccbf80233707dcc3 (patch)
tree3900e13d9d1c8b0557d36b6228bd615fc3c3a166 /recipes-graphics/waffle
parente1b169c907b2d6743f277f1212fcc6ecb2e068c3 (diff)
downloadmeta-freescale-81262efe6e9eb8ac0ed345abccbf80233707dcc3.tar.gz
waffle: fix patch fuzz QA warning
Fix patch fuzz QA warning reported by build, use devtool to correct patches. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-graphics/waffle')
-rw-r--r--recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch10
-rw-r--r--recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch10
2 files changed, 8 insertions, 12 deletions
diff --git a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
index f613386f..b5225693 100644
--- a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
+++ b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
@@ -1,4 +1,4 @@
1From 932c21d2851fe79bf4fe55d3b613f71f65762adb Mon Sep 17 00:00:00 2001 1From 87fc7761cff5931a58984c7f7e78f421a0660e0e Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com> 2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Apr 2020 13:40:04 -0500 3Date: Wed, 22 Apr 2020 13:40:04 -0500
4Subject: [PATCH] meson: Add missing wayland dependency on EGL 4Subject: [PATCH] meson: Add missing wayland dependency on EGL
@@ -9,12 +9,13 @@ missing dependency.
9Upstream-Status: Pending 9Upstream-Status: Pending
10 10
11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> 11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
12
12--- 13---
13 meson.build | 6 ++++-- 14 meson.build | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-) 15 1 file changed, 4 insertions(+), 2 deletions(-)
15 16
16diff --git a/meson.build b/meson.build 17diff --git a/meson.build b/meson.build
17index 957737c..4ebb022 100644 18index ca8b127..efb51f4 100644
18--- a/meson.build 19--- a/meson.build
19+++ b/meson.build 20+++ b/meson.build
20@@ -65,6 +65,7 @@ dep_gl = _dep_null 21@@ -65,6 +65,7 @@ dep_gl = _dep_null
@@ -27,7 +28,7 @@ index 957737c..4ebb022 100644
27 dep_udev = _dep_null 28 dep_udev = _dep_null
28@@ -90,7 +91,8 @@ else 29@@ -90,7 +91,8 @@ else
29 dep_wayland_client = dependency( 30 dep_wayland_client = dependency(
30 'wayland-client', version : '>= 1.0', required : get_option('wayland'), 31 'wayland-client', version : '>= 1.10', required : get_option('wayland'),
31 ) 32 )
32- dep_wayland_egl = dependency( 33- dep_wayland_egl = dependency(
33+ dep_wayland_egl = dependency('egl', required : get_option('wayland')) 34+ dep_wayland_egl = dependency('egl', required : get_option('wayland'))
@@ -44,6 +45,3 @@ index 957737c..4ebb022 100644
44 build_glx = dep_gl.found() 45 build_glx = dep_gl.found()
45 build_gbm = dep_gbm.found() and dep_udev.found() 46 build_gbm = dep_gbm.found() and dep_udev.found()
46 build_surfaceless = dep_egl.found() 47 build_surfaceless = dep_egl.found()
47--
482.17.1
49
diff --git a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
index 3f9f3b1c..9d5003e2 100644
--- a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
+++ b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
@@ -1,7 +1,7 @@
1From 451381a61ad0c96e870da2325fc188eaa3d91fec Mon Sep 17 00:00:00 2001 1From 12ac4372cc6a66e83b61f8510bdaa4f11c72113d Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com> 2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Apr 2020 14:08:36 -0500 3Date: Wed, 22 Apr 2020 14:08:36 -0500
4Subject: [PATCH 2/2] meson: Separate surfaceless option from x11 4Subject: [PATCH] meson: Separate surfaceless option from x11
5 5
6Allow surfaceless build separate from the x11 option. 6Allow surfaceless build separate from the x11 option.
7Also require gbm for surfaceless build. 7Also require gbm for surfaceless build.
@@ -9,12 +9,13 @@ Also require gbm for surfaceless build.
9Upstream-Status: Pending 9Upstream-Status: Pending
10 10
11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> 11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
12
12--- 13---
13 meson.build | 5 ++++- 14 meson.build | 5 ++++-
14 1 file changed, 4 insertions(+), 1 deletion(-) 15 1 file changed, 4 insertions(+), 1 deletion(-)
15 16
16diff --git a/meson.build b/meson.build 17diff --git a/meson.build b/meson.build
17index 4ebb022..0705f61 100644 18index efb51f4..0ee3ee5 100644
18--- a/meson.build 19--- a/meson.build
19+++ b/meson.build 20+++ b/meson.build
20@@ -72,6 +72,7 @@ dep_udev = _dep_null 21@@ -72,6 +72,7 @@ dep_udev = _dep_null
@@ -41,6 +42,3 @@ index 4ebb022..0705f61 100644
41 endif 42 endif
42 43
43 dep_bash = dependency('bash-completion', required : false) 44 dep_bash = dependency('bash-completion', required : false)
44--
452.17.1
46