summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/waffle
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-16 12:12:13 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-17 05:42:39 -0700
commit098012ba8e30ba82afbbe708243879bafd62308e (patch)
tree03d04e33028b1b7f6848b6a7ce47bb1f2492d854 /recipes-graphics/waffle
parent19f0c663947f28a39419e90b01d19b5119cc80da (diff)
downloadmeta-freescale-098012ba8e30ba82afbbe708243879bafd62308e.tar.gz
waffle: Fix waffle patch fuzz
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/waffle')
-rw-r--r--recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
index 5f587d84..6f4be031 100644
--- a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
+++ b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
@@ -14,9 +14,11 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14 meson.build | 6 ++++-- 14 meson.build | 6 ++++--
15 1 file changed, 4 insertions(+), 2 deletions(-) 15 1 file changed, 4 insertions(+), 2 deletions(-)
16 16
17--- a/meson.build 17Index: git/meson.build
18+++ b/meson.build 18===================================================================
19@@ -63,6 +63,7 @@ dep_gl = _dep_null 19--- git.orig/meson.build
20+++ git/meson.build
21@@ -65,6 +65,7 @@ dep_gl = _dep_null
20 dep_egl = _dep_null 22 dep_egl = _dep_null
21 dep_wayland_client = _dep_null 23 dep_wayland_client = _dep_null
22 dep_wayland_egl = _dep_null 24 dep_wayland_egl = _dep_null
@@ -24,7 +26,7 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
24 dep_wayland_scanner = _dep_null 26 dep_wayland_scanner = _dep_null
25 dep_wayland_proto = _dep_null 27 dep_wayland_proto = _dep_null
26 dep_x11_xcb = _dep_null 28 dep_x11_xcb = _dep_null
27@@ -104,7 +105,8 @@ else 29@@ -106,7 +107,8 @@ else
28 dep_wayland_client = dependency( 30 dep_wayland_client = dependency(
29 'wayland-client', version : '>= 1.10', required : get_option('wayland'), 31 'wayland-client', version : '>= 1.10', required : get_option('wayland'),
30 ) 32 )
@@ -34,8 +36,8 @@ Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
34 'wayland-egl', version : '>= 9.1', required : get_option('wayland'), 36 'wayland-egl', version : '>= 9.1', required : get_option('wayland'),
35 ) 37 )
36 dep_wayland_scanner = dependency( 38 dep_wayland_scanner = dependency(
37@@ -120,7 +122,7 @@ else 39@@ -124,7 +126,7 @@ else
38 wayland_xdg_shell_xml = join_paths(dep_wayland_proto.get_pkgconfig_variable('pkgdatadir'), 40 wayland_xdg_shell_xml = join_paths(dep_wayland_proto.get_variable(pkgconfig: 'pkgdatadir'),
39 'stable/xdg-shell/xdg-shell.xml') 41 'stable/xdg-shell/xdg-shell.xml')
40 endif 42 endif
41- build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found() 43- build_wayland = dep_egl.found() and dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_scanner.found() and dep_wayland_proto.found()