summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/piglit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-27 07:47:42 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-27 07:47:42 -0700
commitf8dbb3a7722c9037d10a4d4372992b78aceb51aa (patch)
tree909f455eddcef00a683d7eb33fda9a9a4d2d09b1 /recipes-graphics/piglit
parent77c925566248d09524c8e673cea5045064bc363d (diff)
downloadmeta-freescale-f8dbb3a7722c9037d10a4d4372992b78aceb51aa.tar.gz
piglit: Remove portions which are now in main recipe
Some pieces have been moved to core in [1] [1] https://git.openembedded.org/openembedded-core/commit/?id=53c90930fca17cdaec2a5492320a286b6db6bdda Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/piglit')
-rw-r--r--recipes-graphics/piglit/piglit/0005-cmake-Don-t-enable-GLX-if-tests-are-disabled.patch32
-rw-r--r--recipes-graphics/piglit/piglit_%.bbappend6
2 files changed, 0 insertions, 38 deletions
diff --git a/recipes-graphics/piglit/piglit/0005-cmake-Don-t-enable-GLX-if-tests-are-disabled.patch b/recipes-graphics/piglit/piglit/0005-cmake-Don-t-enable-GLX-if-tests-are-disabled.patch
deleted file mode 100644
index ef6fda0f..00000000
--- a/recipes-graphics/piglit/piglit/0005-cmake-Don-t-enable-GLX-if-tests-are-disabled.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 13ff43fe760ac343b33d8e8c84b89886aac07116 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Fri, 3 Jun 2022 10:44:29 -0500
4Subject: [PATCH] cmake: Don't enable GLX if tests are disabled
5
6Allow building for systems that don't support GLX.
7
8Upstream-Status: Submitted [https://gitlab.freedesktop.org/mesa/piglit/-/merge_requests/720]
9Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
10---
11 CMakeLists.txt | 5 +----
12 1 file changed, 1 insertion(+), 4 deletions(-)
13
14diff --git a/CMakeLists.txt b/CMakeLists.txt
15index e1aeb5ddf..85e171aba 100644
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -134,10 +134,7 @@ if(PIGLIT_BUILD_CL_TESTS)
19 endif(PIGLIT_BUILD_CL_TESTS)
20
21 IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
22- if(X11_FOUND AND OPENGL_gl_LIBRARY)
23- # Assume the system has GLX. In the future, systems may exist
24- # with libGL and libX11 but no GLX, but that world hasn't
25- # arrived yet.
26+ if(X11_FOUND AND OPENGL_gl_LIBRARY AND PIGLIT_BUILD_GLX_TESTS)
27 set(PIGLIT_HAS_GLX True)
28 add_definitions(-DPIGLIT_HAS_GLX)
29 endif()
30--
312.17.1
32
diff --git a/recipes-graphics/piglit/piglit_%.bbappend b/recipes-graphics/piglit/piglit_%.bbappend
index 6a1b9b98..72cf8eff 100644
--- a/recipes-graphics/piglit/piglit_%.bbappend
+++ b/recipes-graphics/piglit/piglit_%.bbappend
@@ -1,10 +1,4 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI += "file://0005-cmake-Don-t-enable-GLX-if-tests-are-disabled.patch"
4
5PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glx', '', d)}"
6PACKAGECONFIG:remove:imxgpu = "glx" 3PACKAGECONFIG:remove:imxgpu = "glx"
7PACKAGECONFIG:append:mx8-nxp-bsp = " opencl" 4PACKAGECONFIG:append:mx8-nxp-bsp = " opencl"
8
9PACKAGECONFIG[glx] = "-DPIGLIT_BUILD_GLX_TESTS=ON,-DPIGLIT_BUILD_GLX_TESTS=OFF"
10PACKAGECONFIG[opencl] = "-DPIGLIT_BUILD_CL_TESTS=ON,-DPIGLIT_BUILD_CL_TESTS=OFF,opencl-icd-loader"