summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/piglit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-13 12:06:26 -0700
committerKhem Raj <raj.khem@gmail.com>2023-03-13 12:06:54 -0700
commit16cdba4e343a0091a5f8b38c581867d1c6c0f54d (patch)
tree553d74e395eea1506ee33ca3c6504fdb90278d95 /recipes-graphics/piglit
parent090079a62f1d9fb54a5be0ae5a57135efb88dfce (diff)
downloadmeta-freescale-16cdba4e343a0091a5f8b38c581867d1c6c0f54d.tar.gz
piglit: Fix build with clang when using NXP BSP
Fixes build errors e.g. tests/egl/egl-util.c:89:9: error: incompatible integer to pointer conversion returning 'Pixmap' (aka 'unsigned long') from a function with result type 'EGLNativePixmapType' (aka 'struct wl_egl_pixmap *') [-Wint-conversion] return XCreatePixmap(state->dpy, state->win, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/piglit')
-rw-r--r--recipes-graphics/piglit/piglit_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-graphics/piglit/piglit_%.bbappend b/recipes-graphics/piglit/piglit_%.bbappend
index 2b7561d1..882d4ddf 100644
--- a/recipes-graphics/piglit/piglit_%.bbappend
+++ b/recipes-graphics/piglit/piglit_%.bbappend
@@ -1,4 +1,5 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3CFLAGS:append:imxgpu:toolchain-clang = " -Wno-error=int-conversion"
3PACKAGECONFIG:remove:imxgpu = "x11 glx" 4PACKAGECONFIG:remove:imxgpu = "x11 glx"
4PACKAGECONFIG:append:mx8-nxp-bsp = " opencl" 5PACKAGECONFIG:append:mx8-nxp-bsp = " opencl"