summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-03-29 16:18:57 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-13 17:30:43 -0300
commitf86588eec76c2d34ec6e63047b7dd4ab9f1b474f (patch)
treea74b1e808b265e21c36265ada3994ba6eeb99891 /recipes-graphics/mesa
parentf98059fef8cf4ca95f19c6a80e567fb44ba1a219 (diff)
downloadmeta-freescale-f86588eec76c2d34ec6e63047b7dd4ab9f1b474f.tar.gz
mesa: For NXP BSP align DRM parts to other GPU parts
With swrast no longer supported, align the DRM parts with the other non-DRM GPU parts, dropping osmesa, swrast, and dri, and restoring gallium. This undoes 3b0fc73. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend22
1 files changed, 2 insertions, 20 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index fce3802e..76f1bc28 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,26 +17,8 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# For NXP BSP, choose between gallium and osmesa, and between enabling 20# For NXP BSP, GPU drivers don't support dri
21# dri and swrast or not. gallium and dri are default. 21PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri"
22#
23# For parts with no GPU, use gallium and dri
24PACKAGECONFIG_REMOVE_NXPBSP = ""
25PACKAGECONFIG_APPEND_NXPBSP = ""
26DRIDRIVERS_NXPBSP = ""
27#
28# For parts with GPU but no DRM, use gallium
29PACKAGECONFIG_REMOVE_NXPBSP_imxgpu = "dri"
30DRIDRIVERS_NXPBSP_imxgpu = ""
31#
32# For parts with GPU and DRM, use osmesa, dri, and swrast
33PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium"
34PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa"
35DRIDRIVERS_NXPBSP_imxgpu_imxdrm = "swrast"
36#
37PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
38PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
39DRIDRIVERS_use-nxp-bsp = "${DRIDRIVERS_NXPBSP}"
40 22
41BACKEND = \ 23BACKEND = \
42 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 24 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \