summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2019-08-17 10:17:01 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-20 21:14:51 -0300
commitbacf6dd96784a814b6a0ec48d7de1f783ffaae52 (patch)
tree4eb774bbffe21497219a1c09e8d95998960488be /recipes-graphics/mesa
parenta1b81241bc3ed8efcbcf5395db0c3eb5b0834d72 (diff)
downloadmeta-freescale-bacf6dd96784a814b6a0ec48d7de1f783ffaae52.tar.gz
mesa: Enable Freedreno when using mainline BSP
The Freedreno allows the i.MX53 SoC to run using the mesa as rendering, thus providing GPU support. Change-Id: I9bf08503f8c6020d50a2395fc27b15cb797cbba6 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 05ea2520..c522315a 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -14,10 +14,10 @@ python () {
14 d.setVarFlag("PACKAGECONFIG", "x11", x11flag.replace("--enable-glx-tls", "--enable-glx")) 14 d.setVarFlag("PACKAGECONFIG", "x11", x11flag.replace("--enable-glx-tls", "--enable-glx"))
15} 15}
16 16
17# Enable Etnaviv support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium"
19GALLIUMDRIVERS_append_use-mainline-bsp_armv7a = ",etnaviv,kmsro,vc4" 19GALLIUMDRIVERS_append_use-mainline-bsp_armv7a = ",etnaviv,freedreno,kmsro,vc4"
20GALLIUMDRIVERS_append_use-mainline-bsp_armv7ve = ",etnaviv,kmsro,vc4" 20GALLIUMDRIVERS_append_use-mainline-bsp_armv7ve = ",etnaviv,freedreno,kmsro,vc4"
21 21
22# Define the osmesa block in PACKAGECONFIG for target, this block is 22# Define the osmesa block in PACKAGECONFIG for target, this block is
23# not defined in the master recipe, effectively causing the osmesa 23# not defined in the master recipe, effectively causing the osmesa