summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-07-05 13:18:39 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-05 15:32:27 -0300
commit681d596e5cbf78cc27d1cdfccd329022242d2c14 (patch)
tree2c6ca32b11ebcdbd2ffbf5487ad728e3eed5fcd7 /recipes-graphics/mesa
parent964a195536b61a4b9bf474a5c783ac888de2e846 (diff)
downloadmeta-freescale-681d596e5cbf78cc27d1cdfccd329022242d2c14.tar.gz
mesa-demos: Fix condition for GLES support
The condition for GLES support was incorrect and would remove GLES for parts with both 2D and 3D. Fix the condition so GLES is removed only for parts with 2D and no 3D. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 2ee7c2b9..94db4157 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -5,9 +5,11 @@ SRC_URI_append_imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos
5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ 5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \
6 file://Add-OpenVG-demos-to-support-wayland.patch" 6 file://Add-OpenVG-demos-to-support-wayland.patch"
7 7
8PACKAGECONFIG_IMX_TO_REMOVE = "" 8PACKAGECONFIG_IMX_TO_REMOVE_GLES = ""
9PACKAGECONFIG_IMX_TO_REMOVE_append_imxgpu2d = "gles1 gles2" 9PACKAGECONFIG_IMX_TO_REMOVE_GLES_imxgpu2d = "gles1 gles2"
10PACKAGECONFIG_IMX_TO_REMOVE_append_imxgpu = " \ 10PACKAGECONFIG_IMX_TO_REMOVE_GLES_imxgpu3d = ""
11PACKAGECONFIG_IMX_TO_REMOVE = "${PACKAGECONFIG_IMX_TO_REMOVE_GLES}"
12PACKAGECONFIG_IMX_TO_REMOVE_append_imxgpu = " \
11 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ 13 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \
12" 14"
13PACKAGECONFIG_remove = "${PACKAGECONFIG_IMX_TO_REMOVE}" 15PACKAGECONFIG_remove = "${PACKAGECONFIG_IMX_TO_REMOVE}"