diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-08-02 11:01:05 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 59d36c9832702989bfcca8a5af29fb2dff01efcc (patch) | |
tree | b2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-graphics/mesa | |
parent | 72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff) | |
download | meta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz |
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r-- | recipes-graphics/mesa/mesa-demos_%.bbappend | 16 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | 4 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa-gl_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 22 |
4 files changed, 22 insertions, 22 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend index 301f1b59..4b518185 100644 --- a/recipes-graphics/mesa/mesa-demos_%.bbappend +++ b/recipes-graphics/mesa/mesa-demos_%.bbappend | |||
@@ -1,26 +1,26 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | SRC_URI_append_imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ | 3 | SRC_URI:append:imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ |
4 | file://fix-clear-build-break.patch \ | 4 | file://fix-clear-build-break.patch \ |
5 | file://Add-OpenVG-demos-to-support-wayland.patch" | 5 | file://Add-OpenVG-demos-to-support-wayland.patch" |
6 | 6 | ||
7 | PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" | 7 | PACKAGECONFIG_REMOVE_IF_2D_ONLY = "" |
8 | PACKAGECONFIG_REMOVE_IF_2D_ONLY_imxgpu2d = "gles1 gles2" | 8 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu2d = "gles1 gles2" |
9 | PACKAGECONFIG_REMOVE_IF_2D_ONLY_imxgpu3d = "" | 9 | PACKAGECONFIG_REMOVE_IF_2D_ONLY:imxgpu3d = "" |
10 | PACKAGECONFIG_REMOVE_IF_GPU = "" | 10 | PACKAGECONFIG_REMOVE_IF_GPU = "" |
11 | PACKAGECONFIG_REMOVE_IF_GPU_imxgpu = " \ | 11 | PACKAGECONFIG_REMOVE_IF_GPU:imxgpu = " \ |
12 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ | 12 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ |
13 | " | 13 | " |
14 | PACKAGECONFIG_remove = " \ | 14 | PACKAGECONFIG:remove = " \ |
15 | ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \ | 15 | ${PACKAGECONFIG_REMOVE_IF_2D_ONLY} \ |
16 | ${PACKAGECONFIG_REMOVE_IF_GPU} \ | 16 | ${PACKAGECONFIG_REMOVE_IF_GPU} \ |
17 | " | 17 | " |
18 | 18 | ||
19 | PACKAGECONFIG_APPEND_IF_GPU = "" | 19 | PACKAGECONFIG_APPEND_IF_GPU = "" |
20 | PACKAGECONFIG_APPEND_IF_GPU_imxgpu = " \ | 20 | PACKAGECONFIG_APPEND_IF_GPU:imxgpu = " \ |
21 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \ | 21 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \ |
22 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glut', '', d)} \ | 22 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glut', '', d)} \ |
23 | " | 23 | " |
24 | PACKAGECONFIG_append = " \ | 24 | PACKAGECONFIG:append = " \ |
25 | ${PACKAGECONFIG_APPEND_IF_GPU} \ | 25 | ${PACKAGECONFIG_APPEND_IF_GPU} \ |
26 | " | 26 | " |
diff --git a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb index 2a32c448..87d05365 100644 --- a/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb +++ b/recipes-graphics/mesa/mesa-etnaviv-env_0.1.bb | |||
@@ -12,7 +12,7 @@ SRC_URI = "\ | |||
12 | do_configure[noexec] = "1" | 12 | do_configure[noexec] = "1" |
13 | do_compile[noexec] = "1" | 13 | do_compile[noexec] = "1" |
14 | 14 | ||
15 | do_install_use-mainline-bsp() { | 15 | do_install:use-mainline-bsp() { |
16 | # MESA global envirronment variables | 16 | # MESA global envirronment variables |
17 | 17 | ||
18 | # systemd | 18 | # systemd |
@@ -28,4 +28,4 @@ do_install_use-mainline-bsp() { | |||
28 | fi | 28 | fi |
29 | } | 29 | } |
30 | 30 | ||
31 | ALLOW_EMPTY_${PN} = "1" | 31 | ALLOW_EMPTY:${PN} = "1" |
diff --git a/recipes-graphics/mesa/mesa-gl_%.bbappend b/recipes-graphics/mesa/mesa-gl_%.bbappend index ca1c8f46..dafd27f0 100644 --- a/recipes-graphics/mesa/mesa-gl_%.bbappend +++ b/recipes-graphics/mesa/mesa-gl_%.bbappend | |||
@@ -1 +1 @@ | |||
COMPATIBLE_MACHINE_imxgpu = "(-)" | COMPATIBLE_MACHINE:imxgpu = "(-)" | ||
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 423ee63e..fedadab2 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -1,5 +1,5 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:" |
2 | SRC_URI_append_use-mainline-bsp = " \ | 2 | SRC_URI:append:use-mainline-bsp = " \ |
3 | file://0001-dri-add-createImageWithModifiers2-interface.patch \ | 3 | file://0001-dri-add-createImageWithModifiers2-interface.patch \ |
4 | file://0002-dri-add-loader_dri_create_image-helper.patch \ | 4 | file://0002-dri-add-loader_dri_create_image-helper.patch \ |
5 | file://0003-loader-dri3-convert-to-loader_dri_create_image.patch \ | 5 | file://0003-loader-dri3-convert-to-loader_dri_create_image.patch \ |
@@ -11,11 +11,11 @@ SRC_URI_append_use-mainline-bsp = " \ | |||
11 | file://0009-etnaviv-flush-used-render-buffers-on-context-flush-w.patch \ | 11 | file://0009-etnaviv-flush-used-render-buffers-on-context-flush-w.patch \ |
12 | " | 12 | " |
13 | 13 | ||
14 | PROVIDES_remove_imxgpu = "virtual/egl" | 14 | PROVIDES:remove:imxgpu = "virtual/egl" |
15 | PROVIDES_remove_imxgpu3d = "virtual/libgl virtual/libgles1 virtual/libgles2" | 15 | PROVIDES:remove:imxgpu3d = "virtual/libgl virtual/libgles1 virtual/libgles2" |
16 | 16 | ||
17 | PACKAGECONFIG_remove_imxgpu = "egl gbm" | 17 | PACKAGECONFIG:remove:imxgpu = "egl gbm" |
18 | PACKAGECONFIG_remove_imxgpu3d = "gles" | 18 | PACKAGECONFIG:remove:imxgpu3d = "gles" |
19 | 19 | ||
20 | # FIXME: mesa should support 'x11-no-tls' option | 20 | # FIXME: mesa should support 'x11-no-tls' option |
21 | python () { | 21 | python () { |
@@ -28,13 +28,13 @@ python () { | |||
28 | } | 28 | } |
29 | 29 | ||
30 | # Enable Etnaviv and Freedreno support | 30 | # Enable Etnaviv and Freedreno support |
31 | PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" | 31 | PACKAGECONFIG:append:use-mainline-bsp = " gallium etnaviv kmsro freedreno" |
32 | 32 | ||
33 | # For NXP BSP, GPU drivers don't support dri | 33 | # For NXP BSP, GPU drivers don't support dri |
34 | PACKAGECONFIG_remove_imxgpu_use-nxp-bsp = "dri" | 34 | PACKAGECONFIG:remove:imxgpu:use-nxp-bsp = "dri" |
35 | 35 | ||
36 | # mainline/etnaviv: | 36 | # mainline/etnaviv: |
37 | RRECOMMENDS_${PN}-megadriver_append_use-mainline-bsp = " libdrm-etnaviv mesa-etnaviv-env" | 37 | RRECOMMENDS:${PN}-megadriver:append:use-mainline-bsp = " libdrm-etnaviv mesa-etnaviv-env" |
38 | 38 | ||
39 | BACKEND = \ | 39 | BACKEND = \ |
40 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | 40 | "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ |
@@ -42,7 +42,7 @@ BACKEND = \ | |||
42 | 'fb', d), d)}" | 42 | 'fb', d), d)}" |
43 | 43 | ||
44 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 44 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
45 | do_install_append_imxgpu3d () { | 45 | do_install:append:imxgpu3d () { |
46 | rm -f ${D}${libdir}/libGL.* \ | 46 | rm -f ${D}${libdir}/libGL.* \ |
47 | ${D}${includedir}/GL/gl.h \ | 47 | ${D}${includedir}/GL/gl.h \ |
48 | ${D}${includedir}/GL/glcorearb.h \ | 48 | ${D}${includedir}/GL/glcorearb.h \ |
@@ -54,6 +54,6 @@ do_install_append_imxgpu3d () { | |||
54 | fi | 54 | fi |
55 | } | 55 | } |
56 | 56 | ||
57 | do_install_append_imxgpu () { | 57 | do_install:append:imxgpu () { |
58 | rm -rf ${D}${includedir}/KHR | 58 | rm -rf ${D}${includedir}/KHR |
59 | } | 59 | } |