summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-06-26 20:55:43 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-29 14:17:08 -0300
commit54e0225ba79ae00f17954c6f5055dddaa0b1fd97 (patch)
treeccda6591c3ae550a0072626cec61275afcc4612e /recipes-graphics/mesa
parent78af77d37275994be154b730ebeb46e86ecab902 (diff)
downloadmeta-freescale-54e0225ba79ae00f17954c6f5055dddaa0b1fd97.tar.gz
mesa-demos: Use the new imxgpu override
Use imxgpu override for GPU 2D or 3D condition Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend21
1 files changed, 8 insertions, 13 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index a1c5b63d..c47dce96 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,24 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_imxgpu2d = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ 3SRC_URI_append_imxgpu = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
4 file://fix-clear-build-break.patch \ 4 file://fix-clear-build-break.patch \
5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ 5 file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \
6 file://Add-OpenVG-demos-to-support-wayland.patch" 6 file://Add-OpenVG-demos-to-support-wayland.patch"
7 7
8PACKAGECONFIG_IMX_TO_REMOVE = "" 8PACKAGECONFIG_IMX_TO_REMOVE = ""
9PACKAGECONFIG_IMX_TO_REMOVE_imxgpu2d = " \ 9PACKAGECONFIG_IMX_TO_REMOVE_append_imxgpu2d = "gles1 gles2"
10 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ 10PACKAGECONFIG_IMX_TO_REMOVE_append_imxgpu = " \
11 gles1 \
12 gles2 \
13"
14PACKAGECONFIG_IMX_TO_REMOVE_imxgpu3d = " \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \ 11 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu x11', '', d)} \
16" 12"
13PACKAGECONFIG_remove = "${PACKAGECONFIG_IMX_TO_REMOVE}"
17 14
18PACKAGECONFIG_IMX_TO_APPEND = "" 15PACKAGECONFIG_IMX_TO_APPEND = ""
19PACKAGECONFIG_IMX_TO_APPEND_imxgpu2d = " \ 16PACKAGECONFIG_IMX_TO_APPEND_append_imxgpu = " \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \ 17 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland vg', '', d)} \
21" 18"
22 19PACKAGECONFIG_append = "${PACKAGECONFIG_IMX_TO_APPEND}"
23PACKAGECONFIG_remove = " ${PACKAGECONFIG_IMX_TO_REMOVE}"
24PACKAGECONFIG_append = " ${PACKAGECONFIG_IMX_TO_APPEND}"