summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-12-07 11:30:58 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2018-03-15 09:50:54 -0300
commit3be3c2736231acb219feb6c00523f9a6f36d28ea (patch)
tree8a099327cfa8cabe87b22f5b117b3015e16ac944 /recipes-graphics/mesa
parent428a3934e9094e8e8c5cbd53bd6d1dfb4d6784e0 (diff)
downloadmeta-freescale-3be3c2736231acb219feb6c00523f9a6f36d28ea.tar.gz
mesa: Remove parts provided by imx-gpu-viv v6
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend20
1 files changed, 17 insertions, 3 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index a89184ec..74396ae8 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,6 +1,6 @@
1PACKAGECONFIG_remove_imxgpu2d = "egl gles" 1PACKAGECONFIG_remove_imxgpu2d = "egl gles gbm"
2 2
3PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" 3PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl gbm"
4PROVIDES_remove_imxgpu3d = "virtual/libgl" 4PROVIDES_remove_imxgpu3d = "virtual/libgl"
5 5
6# FIXME: mesa should support 'x11-no-tls' option 6# FIXME: mesa should support 'x11-no-tls' option
@@ -17,11 +17,25 @@ python () {
17PACKAGECONFIG_append_use-mainline-bsp = " gallium" 17PACKAGECONFIG_append_use-mainline-bsp = " gallium"
18GALLIUMDRIVERS_append_use-mainline-bsp = ",etnaviv,imx" 18GALLIUMDRIVERS_append_use-mainline-bsp = ",etnaviv,imx"
19 19
20BACKEND = \
21 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
22 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
23 'fb', d), d)}"
24
20# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 25# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
21do_install_append_imxgpu3d () { 26do_install_append_imxgpu3d () {
22 rm -f ${D}${libdir}/libGL.* \ 27 rm -f ${D}${libdir}/libGL.* \
23 ${D}${includedir}/GL/gl.h \ 28 ${D}${includedir}/GL/gl.h \
24 ${D}${includedir}/GL/glext.h 29 ${D}${includedir}/GL/glext.h \
30 ${D}${includedir}/GL/glx.h \
31 ${D}${includedir}/GL/glxext.h
32 if [ "${BACKEND}" = "x11" ]; then
33 rm -f ${D}${libdir}/pkgconfig/gl.pc
34 fi
35}
36
37do_install_append_imxgpu2d () {
38 rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc
25} 39}
26 40
27do_install_append_imxgpu2d () { 41do_install_append_imxgpu2d () {