summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-02 12:15:45 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-03 07:56:53 -0300
commit23416520c2aeaf593177adac54c4983c0bf361f2 (patch)
tree3e665022bc652bc60b4cd75c80b268d8d94ae164 /recipes-graphics/mesa
parent156064f4b778ceb595aa18e9e7209f2969069ed7 (diff)
downloadmeta-freescale-23416520c2aeaf593177adac54c4983c0bf361f2.tar.gz
mesa: Disable dri for parts without DRM
On dunfell parts without DRM (i.MX 6 and 7) break because dri is enabled: ``` | meson.build:455:4: ERROR: Problem encountered: building dri drivers require at least one windowing system or classic osmesa ``` The break does not occur on master since dri is effectively disabled if no dri drivers are configured. Disabling dri outright is still a better implementation on master, and of course is required on dunfell. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 4f38acd9..b6dbcc2f 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,10 +17,15 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# For NXP BSP, enable OSMesa for parts with DRM 20# For NXP BSP, disable dri for parts without DRM.
21# Also enable swrast for its dri driver 21# Disable gallium and enable OSMesa for parts with DRM.
22PACKAGECONFIG_remove_use-nxp-bsp_imxdrm = "gallium" 22# Also enable swrast for its dri driver for parts with DRM.
23PACKAGECONFIG_append_use-nxp-bsp_imxdrm = " osmesa" 23PACKAGECONFIG_REMOVE_NXPBSP = "dri"
24PACKAGECONFIG_APPEND_NXPBSP = ""
25PACKAGECONFIG_REMOVE_NXPBSP_imxdrm = "gallium"
26PACKAGECONFIG_APPEND_NXPBSP_imxdrm = "osmesa"
27PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
28PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
24DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast" 29DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast"
25 30
26BACKEND = \ 31BACKEND = \