summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-04 12:55:22 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-16 11:46:12 -0300
commit148581622b1097123f0fdb905c3167d0d6d6f5b7 (patch)
tree9d1c0c12ee713ea532bc76d8bc10639746af5f8b /recipes-graphics/mesa
parent6078f458b6aa24411a733f4238ef7358183dddaf (diff)
downloadmeta-freescale-148581622b1097123f0fdb905c3167d0d6d6f5b7.tar.gz
mesa: For i.MX parts without GPU use default gallium and dri
For NXP BSP, building graphics software for a part without GPU can fail with a dependency issue: ``` ERROR: Nothing RPROVIDES 'libgl' (but /home/r60874/gatesgarth/sources/poky/meta/recipes-gnome/gtk+/gtk+3_3.24.22.bb, /home/r60874/gatesgarth/sources/poky/meta/recipes-graphics/cogl/cogl-1.0_1.22.8.bb RDEPENDS on or otherwise requires it) ``` This is fixed by adding a third case configuration using the default gallium and dri. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend30
1 files changed, 20 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index b6dbcc2f..fce3802e 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -17,16 +17,26 @@ python () {
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium etnaviv kmsro freedreno"
19 19
20# For NXP BSP, disable dri for parts without DRM. 20# For NXP BSP, choose between gallium and osmesa, and between enabling
21# Disable gallium and enable OSMesa for parts with DRM. 21# dri and swrast or not. gallium and dri are default.
22# Also enable swrast for its dri driver for parts with DRM. 22#
23PACKAGECONFIG_REMOVE_NXPBSP = "dri" 23# For parts with no GPU, use gallium and dri
24PACKAGECONFIG_APPEND_NXPBSP = "" 24PACKAGECONFIG_REMOVE_NXPBSP = ""
25PACKAGECONFIG_REMOVE_NXPBSP_imxdrm = "gallium" 25PACKAGECONFIG_APPEND_NXPBSP = ""
26PACKAGECONFIG_APPEND_NXPBSP_imxdrm = "osmesa" 26DRIDRIVERS_NXPBSP = ""
27PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}" 27#
28PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}" 28# For parts with GPU but no DRM, use gallium
29DRIDRIVERS_use-nxp-bsp_imxdrm = "swrast" 29PACKAGECONFIG_REMOVE_NXPBSP_imxgpu = "dri"
30DRIDRIVERS_NXPBSP_imxgpu = ""
31#
32# For parts with GPU and DRM, use osmesa, dri, and swrast
33PACKAGECONFIG_REMOVE_NXPBSP_imxgpu_imxdrm = "gallium"
34PACKAGECONFIG_APPEND_NXPBSP_imxgpu_imxdrm = "osmesa"
35DRIDRIVERS_NXPBSP_imxgpu_imxdrm = "swrast"
36#
37PACKAGECONFIG_remove_use-nxp-bsp = "${PACKAGECONFIG_REMOVE_NXPBSP}"
38PACKAGECONFIG_append_use-nxp-bsp = " ${PACKAGECONFIG_APPEND_NXPBSP}"
39DRIDRIVERS_use-nxp-bsp = "${DRIDRIVERS_NXPBSP}"
30 40
31BACKEND = \ 41BACKEND = \
32 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 42 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \