summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-apitrace
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-11 12:04:11 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-16 11:45:41 -0300
commit6078f458b6aa24411a733f4238ef7358183dddaf (patch)
tree8b7484ac335b33e210920a0c8d0dbb51a1d0fbea /recipes-graphics/imx-gpu-apitrace
parentea0559e137de4823745baf1ef2bca8af972564aa (diff)
downloadmeta-freescale-6078f458b6aa24411a733f4238ef7358183dddaf.tar.gz
imx-gpu-apitrace: Upgrade for eglretrace support
eglretrace was not available for i.MX 6 and 7 on framebuffer or wayland. For wayland, waffle is enabled for 6 and 7, matching i.MX 8. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-gpu-apitrace')
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb25
1 files changed, 17 insertions, 8 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
index 2f8029a4..65ce9cd5 100644
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
@@ -5,19 +5,28 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=aeb969185a143c3c25130bc2c3ef9a50"
5DEPENDS = "imx-gpu-viv zlib libpng procps" 5DEPENDS = "imx-gpu-viv zlib libpng procps"
6 6
7SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_9.0" 7SRC_URI = "git://source.codeaurora.org/external/imx/apitrace-imx.git;protocol=https;branch=imx_9.0"
8SRCREV = "fed74f6f84cb4f48ddace4306c9bf90bf7a9a967" 8SRCREV = "c50e6a954e44998f2e3793a8de863e961f8008c6"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12inherit cmake pkgconfig perlnative python3native 12inherit cmake pkgconfig perlnative python3native
13 13
14PACKAGECONFIG ??= "egl" 14PACKAGECONFIG_BACKEND_mx6 = " \
15PACKAGECONFIG_append = \ 15 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'waffle', \
16 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ 16 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
17 bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', \ 17 '', d), d)} \
18 '', d), d)}" 18"
19PACKAGECONFIG_append_mx8 = " waffle" 19PACKAGECONFIG_BACKEND_mx7 = "${PACKAGECONFIG_BACKEND_mx6}"
20PACKAGECONFIG_append_imxgpu2d = " vivante" 20PACKAGECONFIG_BACKEND_mx8 = "waffle"
21
22PACKAGECONFIG_GPU2D = ""
23PACKAGECONFIG_GPU2D_imxgpu2d = "vivante"
24
25PACKAGECONFIG ??= " \
26 egl \
27 ${PACKAGECONFIG_BACKEND} \
28 ${PACKAGECONFIG_GPU2D} \
29"
21 30
22PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl" 31PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl"
23PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF" 32PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF"